我是靠谱客的博主 冷傲手链,最近开发中收集的这篇文章主要介绍Team Queue(poj 2259),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001
#include<iostream>
#include<string>
using namespace std;
const int maxp=1000000;
const int maxt=1000;
const int maxn=200000+10;
 
 struct node
 	{
 		int p;
 		int pre,next;
	 }r[maxn];
 int used;                //队列新节点的下标 
 int belong[maxp];        //元素所在团队 
 int pos[maxt];           //团队i中最后一个最后一个元素在队列中的位置 
 int st,ed;           //队首队尾指针 
 
 int main(void)
 {
 	int t,loop=0;
 	cin>>t;
 	while(t)
 	{
 		for (int i=0;i<t;i++)
 		{
 			int m;
 			cin>>m;
 			for(int j=0;j<m;j++)
 			{
 				int x;
 				cin>>x;
 				belong[x]=i;
			 }
			 pos[i]=-1;  
		 }
		 used=0;
		 st=ed=-1;
		  
		 if(loop)  //非第一测试用例输出空行
		    cout<<endl;
		cout<<"Scenario #"<<++loop<<endl;
		string s; 
		cin>>s;
		while(s!="STOP")
		{
			if(s=="ENQUEUE")
			{
				int x;
				cin>>x;
				r[used].p=x;
				int s=pos[belong[x]];
				if(s<0)     //队列无此团队元素处理 
				{
					r[used].pre=ed;
					r[used].next=-1;
					if(ed>=0)
					  r[ed].next=used;
                    ed=used;           //类似于双向链表 
				    if(st<0)
					 st=used; 
				}
				else
				{
					r[used].pre=s;
					r[used].next=r[s].next;
					if(s==ed)         //若是最后一个团队 
					   ed=used;
					r[s].next= used;
					if(r[used].next>=0)
					r[r[used].next].pre=used;
				}
				pos[belong[x]]=used++;
			} 
			else                  //处理输出 
			{
				cout<<r[st].p<<endl;
				if(st==pos[belong[r[st].p]])
				pos[belong[r[st].p]]=-1;
				st=r[st].next;
			}
			cin>>s;
		}    
          cin>>t;	
	 }
 	return 0;
 }

这题花了好长时间,其实运用双向链表还是很容易的,指针的实现就是借助指向地址的变量来实现。这个代码理解队列,只能从逻辑上想,不能从存储结构上去考虑队列的排列

最后

以上就是冷傲手链为你收集整理的Team Queue(poj 2259)的全部内容,希望文章能够帮你解决Team Queue(poj 2259)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(70)

评论列表共有 0 条评论

立即
投稿
返回
顶部