我是靠谱客的博主 俊秀悟空,最近开发中收集的这篇文章主要介绍hdu 1387 Team Queue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005

260001

分析:

题意就是模拟食堂买饭的时候你要是发现前面有熟人就去插队这样的事 = = ,,一般的方法是链表模拟,我也试过用两个队列来做但是超时,发现别人的博客如果用优先队列的话就可以 。优先队列的思路就是自定义比较函数里面按两种方式定义优先级。 链表模拟有一个细节不注意就会RE。

代码:

#include<iostream>
#include<stdlib.h>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
struct node
{
    int val;
    node *next;
}*last,*head;
node* team[1000+5];
map<int,int>tid;
int n,num;
void init()
{
    tid.clear();//num=0;
    head=last=(node*)malloc(sizeof(node));
    //head=last=(node*)malloc(sizeof(node));
    head->next=NULL;
    for(int i=1;i<=n;i++)
        team[i]=NULL;
}
void in()
{
    int k;
    node* t;

    scanf("%d",&k);
    t=(node*)malloc(sizeof(node));
  //  t=&a[num++];
    t->val=k;t->next=NULL;
    int ttid=tid[k];
    if(team[ttid]==NULL)
    {
        team[ttid]=t;
        last->next=t;
        last=t;
    }
    else
    {
        node *p;
        p=team[ttid];
        t->next=p->next;
        p->next=t;
        team[ttid]=t;
        if(last==p)     //此处要注意,否则RE
            last=t;
    }

}
void out()
{
    int k=head->next->val;
    int kk=tid[k];
    if(head->next==team[kk])
    {
        printf("%dn",k);
        team[kk]=NULL;
    }
    else
       printf("%dn",k);


   head=head->next;

}
int main()
{
    int cas=1;
    while(scanf("%d",&n),n)
    {
        printf("Scenario #%dn",cas++);
        init();
        for(int i=1;i<=n;i++)
        {
            int k;
            scanf("%d",&k);
            for(int j=1;j<=k;j++)
            {
                int kk;
                scanf("%d",&kk);
                tid[kk]=i;
            }
        }
        char ss[200];
        while(1)
        {
            scanf("%s",ss);
            if(strcmp(ss,"STOP")==0)
                break;
            else if(strcmp(ss,"ENQUEUE")==0)
                in();
            else
                out();
        }
        printf("n");

    }


    return 0;
}


最后

以上就是俊秀悟空为你收集整理的hdu 1387 Team Queue的全部内容,希望文章能够帮你解决hdu 1387 Team Queue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(60)

评论列表共有 0 条评论

立即
投稿
返回
顶部