我是靠谱客的博主 震动期待,最近开发中收集的这篇文章主要介绍hdu QueuingQueuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 608    Accepted Submission(s): 278
 
Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.
Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue. Your task is to calculate the number of E-queues mod M with length L by writing a program.
 
Input
Input a length L (0 <= L <= 10 6) and M.
 
Output
            Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 
Sample Input
3 8
4 7
4 8
 
Sample Output
6
2
1
 
Author
WhereIsHeroFrom
 
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
 
Recommend
lcy
 

分析:开始研究4种状态fm,ff,mm,mf,TLE。接着研究6种状态 ffm,fmm,mfm,mmm,mff,mmf,继续超时。只好从队末加入往前分析,若新来的s[n]=m,那么n前面只要合法这个就合法,即f[n]+=f[n-1]。若新来一个f,那么必须s[n-2]=m。此时,若f[n-1]=m,那么n-2前面合法这个就合法,即f[n]+=f[n-3];若f[n-1]=f,那么必须f[n-3]=m,那么只要n-3前面合法这个就合法,即f[n]+=f[n-4]。

#include <stdio.h>
#define N 1000001
#define M 30

char node[N][M];

void init()
{
    int i,j;
    for(i=1;i<=M;i++)
    {
        node[1][i]=2%i;
        node[2][i]=4%i;
        node[3][i]=6%i;
        node[4][i]=9%i;
        for (j=5;j<=N;j++)
        {
            node[j][i]=(node[j-1][i]+node[j-3][i]+node[j-4][i])%i;
        }
    }
}

int main()
{
    init();
    int n,m;
    while (~scanf("%d%d",&n,&m))
    {
        printf("%dn",node[n][m]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/baidongtan/archive/2012/08/31/2664733.html

最后

以上就是震动期待为你收集整理的hdu QueuingQueuing的全部内容,希望文章能够帮你解决hdu QueuingQueuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部