概述
题目:
输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。
在判断是否满足条件时,字母不分大小写,但在输入时应保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)
样例输入:
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
样例输出:
Disk
NotE
derail
drIed
eye
ladder
soon
#include<iostream>
#include<string>
#include<vector>
#include<map>
// #include<algorithm>1
using namespace std;
map<string,int> cnt;
vector<string> words;
string repr(string s) //简单词进行标准化
{
string ans = s;
for(int i=0 ; i<ans.length(); i++)
ans[i] = tolower(ans[i]);
sort(ans.begin(),ans.end());
return ans;
}
int main()
{
int n;
string s;
while(cin>>s)
{
if(s[0]=='#')break;
words.push_back(s);
string r = repr(s);
if(!cnt.count(r))cnt[r]=0;
cnt[r]++;
}
vector<string>ans;
for(int i=0;i<words.size();i++)
{
if(cnt[repr(words[i])] == 1)
ans.push_back(words[i]);
}
sort(ans.begin(), ans.end());
for(int i=0 ; i<ans.size() ;i++)
cout<<ans[i]<<endl;
return 0;
}
最后
以上就是高大红酒为你收集整理的(C++)反片语(map)的全部内容,希望文章能够帮你解决(C++)反片语(map)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复