概述
1.在字符串中查找指定字符(90分)
题目内容: 在字符串中查找指定字符。编写函数char *findChar(char *s, char
c),利用指针访问方式,在s指向的字符串中查找字符c,若找到,则把字符串中首次出现的c的地址返回,否则返回NULL。在main函数中验证该函数的正确性,输出字符串中c及之后的内容,或者输出No found。
输入格式: 第一行:输入一个字符串,字符串长度小于100。 第二行:要查找的字符。 输入范围包含整个ASCII字符集(包括空格)。
输出格式: 输出字符串中c之后的内容,或者输出No found。
输入样例: sajkajkajsafaa j
输出样例: jkajkajsafaa
#include<iostream>
using namespace std;
char* FindChar(char* str, char ch) {
for (int i = 0; str[i] != 0; i++)
if (str[i] == ch)
return &str[i];
return NULL;
}
int main() {
char str[101], ch;
cin.getline(str, 100);
cin.get(ch);
char* res = FindChar(str, ch);
if (!res) cout << "No found";
else cout << res;
return 0;
}
2.A+B(100分) 题目内容:
输入字符串A+B,输出它们的和C。设计两个函数,一个函数void separate(char
s,chars1,char*s2),将输入的字符串中的两个加数A与B分割出来。再设计一个函数void add(char s1,chars2)计算A+B的和。 输入格式: 一个包含两个数值序列和一个加号的字符串输出格式: 输出C
输入样例: 11111111111111111111111111111111111+1111111111111111111111111111
输出样例: 11111112222222222222222222222222222
#include<iostream>
using namespace std;
void Separate(char* s, char* s1, char* s2) {
//若s为125+12349
int index_s1 = 0, index_s2 = 0;
//index_s1为5的下标——2。index_s2为9的下标——8。
while (s[index_s1++] != '+') {}
index_s1 -= 2;
while (s[index_s2++] != 0) {}
index_s2 -= 2;
//s1存储的内容是521,s2存储的内容是94321
for (int i = index_s1; i >= 0; i--) s1[index_s1 - i] += s[i];
for (int j = index_s2; s[j] != '+'; j--) s2[index_s2 - j] += s[j];
}
void Add(char* s, char* s1, char* s2) {
int res[101] = { 0 };
//存储s1+s2的结果
int p1 = 0, p2 = 0;
while (s1[p1] != 0) {
s1[p1] -= '0';
p1++;
}
while (s2[p2] != 0) {
s2[p2] -= '0';
p2++;
}
for (int i = 0; i <= 100; i++) {
res[i] += s1[i] + s2[i];
}
for (int i = 0; i <= 100; i++) {
if (res[i] >= 10) {
res[i] -= 10;
res[i + 1] += 1;
}
}
int place_of_last_num = 100;
//例如:213459的最后一个数的下标为5
while (res[place_of_last_num] <= 0) place_of_last_num--;
for (int k = place_of_last_num; k >= 0; k--) cout << res[k];
}
int main() {
char s[100] = { 0 }, s1[100] = { 0 }, s2[100] = { 0 };
cin >> s;
Separate(s, s1, s2);
Add(s, s1, s2);
return 0;
}
3.字符串排序(20分)
题目内容: 设计一个函数void input(char ** ps, int n)完成n个不等长字符串的输入,用new运算符根据实际输入的字符串长度分配存储空间,依次使指针数组中的元素指向每一个输入的字符串;设计一个函数void
sort(char ** ps, int
n)完成n个字符串排序(在排序的过程中,要求只交换指向字符串的指针值,不交换字符串);设计一个函数void release(char **
ps, int n)将n个字符串的空间delete在主函数中定义一个指向字符串的指针数组,完成将排序后的字符串输出。输入格式: 先输入一个整数代表字符串个数,然后输入字符串,字符串可包含空格。
输出格式: 输出排序后的字符串
输入样例: 5 sfafajksjfks fsdfdgd ggkdsklskl;sksdkgslklgs dgs gsgfdgfd
输出样例: dgs fsdfdgd ggkdsklskl;sksdkgslklgs gsgfdgfd sfafajksjfks
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
bool compare(char *p1,char *p2) {
if (strcmp(p1,p2)<0) return true;
else return false;
}
void Input(char** ps, int n) {
for (int i = 0; i < n; i++) {
ps[i] = new char[100];
cin >>ps[i];
}
}
void Sort(char** ps, int n) {
sort(&ps[0], &ps[0] + n, compare);
for (int i = 0; i < n; i++) {
cout << ps[i] << endl;
}
}
void Release(char** ps, int n) {
for (int i = 0; i < n; i++) {
delete[] ps[i];
}
}
int main() {
char** ps = { NULL };
int n;
cin >> n;
ps = new char* [n];
Input(ps, n);
Sort(ps, n);
Release(ps, n);
return 0;
}
最后
以上就是英俊乐曲为你收集整理的第8章作业2的全部内容,希望文章能够帮你解决第8章作业2所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复