我是靠谱客的博主 威武豆芽,最近开发中收集的这篇文章主要介绍POJ  1753  Flip Game,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Flip Game
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14504Accepted: 6218

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

POJ <wbr> <wbr>1753 <wbr> <wbr>Flip <wbr>GameConsider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000
唉,郁闷啊,研究了一整晚加上一整上午才弄出来。
这个题就是用枚举举遍所有情况,然后一个一个深搜看看是不是符合条件,符合条件直接退出,不符合则继续,由于表格只有16个所以可以得知最多的步数只能是16,所以可以根据步数从0到16依次枚举,第一个符合条件的就是最小的步数,为了容易深搜,可以设定顺序为一行一行深搜,当一行搜完时从下一行开头搜,代码和测试数据如下:
#include<stdio.h>
int map[4][4],step,flag=0;
void turn(int i,int j)//转换
{
map[i][j]=!map[i][j];
if(i>0)
map[i-1][j]=!map[i-1][j];
if(i<3)
map[i+1][j]=!map[i+1][j];
if(j>0)
map[i][j-1]=!map[i][j-1];
if(j<3)
map[i][j+1]=!map[i][j+1];
}
int range()//判定表格是否全部一样
{
int i,j;
for(i=0;i<4;i++)
for(j=0;j<4;j++)
if(map[i][j]!=map[0][0])
return 0;
return 1;
}
int DFS(int i,int j,int dp)//深搜
{
if(dp==step){
flag=range();
return 0;
}
if(flag||i==4)return 1;
turn(i,j);
if(j<3)DFS(i,j+1,dp+1);
else DFS(i+1,0,dp+1);
turn(i,j);
if(j<3)DFS(i,j+1,dp);
else DFS(i+1,0,dp);
return 0;
}
int main()
{
int i,j;
char a;
for(i=0;i<4;i++)
{
for(j=0;j<4;j++)
{
scanf("%c",&a);
if(a=='b')map[i][j]=0;
else map[i][j]=1;
}
getchar();
}
for(step=0;step<=16;step++)
{
flag=0;
DFS(0,0,0);
if(flag)break;
}
if(flag)printf("%dn",step);
else printf("Impossiblen");
return 0;
}

官方测试数据: 这些都过了,就不可能WA了。

bwbw
wwww
bbwb
bwwb
Impossible

bwwb
bbwb
bwwb
bwww
4

wwww
wwww
wwww
wwww
0

bbbb
bbbb
bbbb
bbbb
0

bbbb
bwbb
bbbb
bbbb
Impossible

bwbb
bwbb
bwbb
bbbb
Impossible

bwbb
wwwb
bwbb
bbbb
1

wwww
wwwb
wwbb
wwwb
1

wwww
wwww
wwwb
wwbb
1

wbwb
bwbw
wbwb
bwbw
Impossible

bbbb
bwwb
bwwb
bbbb
4

bwwb
wbbw
wbbw
bwwb
4

bbww
bbww
wwbb
wwbb
Impossible

bbwb
bbbw
wwbb
wwwb
Impossible

wwwb
wwbw
wbww
wwbw
Impossible

bbbb
wwww
wwbb
wbbb
Impossible

bwwb
wbwb
wbbb
wbbb
4

bwbb
bwbb
bwbw
bbbw
5

wbwb
bbbb
bbww
wbbb
6

bbwb
bbbb
wbwb
bbbb
5

最后

以上就是威武豆芽为你收集整理的POJ  1753  Flip Game的全部内容,希望文章能够帮你解决POJ  1753  Flip Game所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部