我是靠谱客的博主 谦让香水,最近开发中收集的这篇文章主要介绍F - Large Division(大数取模模板),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

模板体,没有技术含量,在此记录一下,以便复习。

AC代码如下:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<map>
#include<vector>
#include<set>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
	int n,i;
	ll ans,b;
	char a[700];
	scanf("%d",&n);
	int k=1;
	while(n--)
	{
		scanf("%s%lld",a,&b);
		ans=0;
		if(b<0)	b=-1*b;
		for(i=0;i<strlen(a);i++)
		{
			if(a[0]=='-')	a[i]='0';
			ans=(ans*10+(a[i]-'0'))%b;
		}
		if(ans==0)
			printf("Case %d: divisiblen",k++);
		else
			printf("Case %d: not divisiblen",k++);
	}
	return 0;
}

 

最后

以上就是谦让香水为你收集整理的F - Large Division(大数取模模板)的全部内容,希望文章能够帮你解决F - Large Division(大数取模模板)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部