概述
两个有序链表序列的交集(使用STL)
已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。
输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。
输出格式:
在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。
输入样例:
1 2 5 -1
2 4 5 8 10 -1
输出样例:
2 5
代码:
STL中关于(交,并,差,对称差)等集合运算函数的用法并不难,大家可以自己搜索进行详细了解
#include<bits/stdtr1c++.h>
using namespace std;
list<int> ls1, ls2, ls3;
int main() {
int t1, t2;
while (scanf("%d", &t1) && t1 != -1) ls1.emplace_back(t1);
while (scanf("%d", &t2) && t2 != -1) ls2.emplace_back(t2);
//下面使用STL中提供的函数求交集
set_intersection(ls1.begin(), ls1.end(), ls2.begin(), ls2.end(), inserter(ls3, ls3.begin()));
if (!ls3.empty()) {
for (auto it = ls3.begin(); it != ls3.end(); it++) {
if (it == ls3.begin()) printf("%d", *it);
else printf(" %d", *it);
}
} else
printf("NULL");
return 0;
}
最后
以上就是开朗蜜粉为你收集整理的1.两个有序链表序列的交集(STL)的全部内容,希望文章能够帮你解决1.两个有序链表序列的交集(STL)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复