概述
Ultra-QuickSort
Time Limit: 7000MS | Memory Limit: 65536K | |
Total Submissions: 67666 | Accepted: 25338 |
Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Ultra-QuickSort produces the output
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5 9 1 0 5 4 3 1 2 3 0
Sample Output
6
0
题解 :归并算法应用:
#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[500005],t[500005];
ll ans=0;
void fun(int l,int r){if(l==r) // 拆分成单个数字
return ;
int mid=(l+r)>>1;
fun(l,mid); // 递归拆分
fun(mid+1,r);
int i=l,j=mid+1,p=l; // 分成两部分依次合并
while(i<=mid&&j<=r){
if(a[i]>a[j]){
t[p++]=a[j++];
ans+=(mid-i+1); //此时两边都是排好序了的,当前面的序列中有一个数大于后面的一个数时,前面序列中剩下的数都大于这个数,共mid-i+1个
}
else{
t[p++]=a[i++];
}
}
while(i<=mid){
t[p++]=a[i++];
}
while(j<=r){
t[p++]=a[j++];
}
for(int i=l;i<=r;i++){
a[i]=t[i];
}
}
int main(){
int n;
while(scanf("%d",&n),n){
ans=0;
for(int i=0;i<n;i++){
scanf("%lld",&a[i]);
}
fun(0,n-1);
printf("%lldn",ans);
}
return 0;
}
最后
以上就是矮小冬日为你收集整理的归并排序 + 求逆序对数的全部内容,希望文章能够帮你解决归并排序 + 求逆序对数所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复