我是靠谱客的博主 和谐溪流,最近开发中收集的这篇文章主要介绍HDU 125 统计难题 (字典树),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc
Sample Output
2
3
1
0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <algorithm>
using namespace std;

typedef struct node{
	int cnt;
	node *next[26];
	node(){
		cnt=0;
		for (int i=0; i<26; i++){
			next[i]=NULL;
		}
	}
}node;
node *root=new node;
void insert(char *str){
	node *cur=root;
	int len=strlen(str);
	for (int i=0; i<len; i++){
		int id=str[i]-'a';
		if (cur->next[id]==NULL){
			node *t=new node;
			cur->next[id]=t;
		}
		cur=cur->next[id];
		cur->cnt++;
	}
}
int query(char *str){
	node *cur=root;
	int len=strlen(str);
	for (int i=0; i<len; i++){
		int id=str[i]-'a';
		if (cur->next[id]!=NULL){
			cur=cur->next[id];
		}else{
			return 0;
		}
	}
	return cur->cnt;
}
void deleteTree(node *p){
	for (int i=0; i<26; i++){
		if (p->next[i]!=NULL){
			delete(p->next[i]);
		}
	}
	delete(p);
}
int main(){
	char str[20];
	while (cin.getline(str, 20)){
		if (str[0]==''){
			break;
		}
		insert(str);
	}
	while(cin.getline(str, 20)){
		printf("%dn", query(str));
	}
	deleteTree(root);
	return 0;
}

最后

以上就是和谐溪流为你收集整理的HDU 125 统计难题 (字典树)的全部内容,希望文章能够帮你解决HDU 125 统计难题 (字典树)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(58)

评论列表共有 0 条评论

立即
投稿
返回
顶部