概述
Agri-Net
Time Limit: 1000ms Memory limit: 10000K 有疑问?点这里^_^
题目描述
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
The distance between any two farms will not exceed 100,000.
输入
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
输出
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
示例输入
4 0 4 9 21 4 0 8 17 9 8 0 16 21 17 16 0
示例输出
28
来源
USACO 102
#include<stdio.h>
#include<string.h>
#define inf 2147483647
int a[1010],map[1010][1010],visited[1010],lowc[1010];
int n,t;
int prime()
{
int i,j,p;
int minc,res=0;
memset(visited,0,sizeof(visited));
visited[0]=1;
for(i=0;i<t;i++)
{
lowc[i]=map[0][i];
}
for(i=1;i<t;i++)
{
minc=inf;
p=-1;
for(j=0;j<t;j++)
{
if(visited[j]==0&&minc>lowc[j])
{
minc=lowc[j];
p=j;
}
}
res+=minc;
visited[p]=1;
for(j=0;j<t;j++)
{
if(visited[j]==0&&lowc[j]>map[p][j])
{
lowc[j]=map[p][j];
}
}
}
return res;
}
int main()
{
int i,j,m,k;
while(scanf("%d",&t)!=EOF)
{
for(i=0;i<t;i++)
for(j=0;j<t;j++)
{
scanf("%d",&m);
if(j==i)
map[i][j]=inf;
else
map[i][j]=m;
}
k=prime();
printf("%dn",k);
}
}
最后
以上就是坦率纸鹤为你收集整理的Agri-Net的全部内容,希望文章能够帮你解决Agri-Net所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复