概述
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 14262 | Accepted: 7982 |
Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
题目链接:点击打开链接
题目大意:有几头牛,每头牛都有不同的等级,先输入n和m两组数,n代表牛的数量,接下来的m行,每行两组数据,左边的牛的等级大于右边的牛的等级。问最后有几头牛可以确定等级。
这道题当时第一眼看到以为是并查集,后来发现不对,最后在算法竞赛入门经典上看到相关解法,这道题属于传递闭包问题,判断有多少条路是可以连通的,用floyd算法就可一些出来。
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<vector>
using namespace std;
int map[105][105];
int main(){
int n,m;
while(~scanf("%d %d",&n,&m)){
memset(map,0,sizeof(map));
int i,j,k,a,b;
for(i=1;i<=m;i++){
scanf("%d %d",&a,&b);
map[a][b]=1;//表示牛a和牛b之间可以联通
}
//Floyd-Warshall算法的核心思想
for(k=1;k<=n;k++){
for(i=1;i<=n;i++){
for(j=1;j<=n;j++){
if(map[i][k]&&map[k][j]){
map[i][j]=1;/*判断i号顶点和j号顶点之间是否
可以联通 ,就需要判断i和j之间的k个顶点之间是否
可以联通,如果其中有任意一个无法联通则i j之间就
无法联通*/
}
}
}
}
int sum;
sum=0;
for(i=1;i<=n;i++){
int ans;
ans=n-1;
for(j=1;j<=n;j++){
if(map[i][j]||map[j][i]){
ans--;/*顶点i和顶点j之间有一个点可以联通 */
}
}
if(!ans){
sum++;
}
}
printf("%dn",sum);
}
return 0;
}
最后
以上就是务实春天为你收集整理的poj3660——Cow Contest【最短路】的全部内容,希望文章能够帮你解决poj3660——Cow Contest【最短路】所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复