我是靠谱客的博主 小巧咖啡豆,最近开发中收集的这篇文章主要介绍CF1495A题解题目思路代码实现,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

CF1495A题解

  • 题目
    • 链接
    • 字面描述
      • 题面翻译
        • 输入格式
        • 输出格式
      • 题目描述
      • 输入格式
      • 输出格式
      • 样例 #1
        • 样例输入 #1
        • 样例输出 #1
        • 提示
  • 思路
  • 代码实现

题目

链接

http://oi.hdoi.cn/problem/CF-1495A

字面描述

题面翻译

题目链接

在一个平面直角坐标系上,有 n n n 个矮人与 n n n 个钻石。保证所有矮人都在 y y y 轴上,所有钻石都在 x x x 轴上,且没有东西在原点

现在,每个矮人都需要去捡一个钻石。假设矮人和钻石的坐标分别为 ( x , y ) , ( u , v ) (x,y),(u,v) (x,y),(u,v),那么这个矮人去捡这个钻石所花费的体力就是 ( x − u ) 2 + ( y − v ) 2 sqrt{(x-u)^2+(y-v)^2} (xu)2+(yv)2 (也就是两点间的距离)

求一个钻石的分配方案,使得所有矮人花费的总体力最少,并输出这个最小值

输入格式

本题有多组数据
第一行一个整数 T T T,表示数据的组数

对于每组数据:
第一行一个整数 n n n,表示矮人与钻石的个数
接下来 2 ⋅ n 2cdot n 2n 行,每行两个整数 x , y x,y x,y
x = 0 x=0 x=0 则代表 ( 0 , y ) (0,y) (0,y) 处有一个矿工
y = 0 y=0 y=0,则代表 ( x , 0 ) (x,0) (x,0) 出有一个钻石

输出格式

对于每组数据,输出一行一个实数,表示最小的总体力花费
你需要保证与答案的相对误差 < 1 0 − 9 <10^{-9} <109

说明与提示

1 ≤ T ≤ 10 1 le T le 10 1T10
1 ≤ n ≤ 1 0 5 , ∑ n ≤ 1 0 5 1le n le 10^5,sum nle 10^5 1n105,n105
∣ x ∣ , ∣ y ∣ ≤ 1 0 8 |x|,|y|le 10^8 x,y108

题目描述

Diamond Miner is a game that is similar to Gold Miner, but there are $ n $ miners instead of $ 1 $ in this game.

The mining area can be described as a plane. The $ n $ miners can be regarded as $ n $ points on the y-axis. There are $ n $ diamond mines in the mining area. We can regard them as $ n $ points on the x-axis. For some reason, no miners or diamond mines can be at the origin (point $ (0, 0) $ ).

Every miner should mine exactly one diamond mine. Every miner has a hook, which can be used to mine a diamond mine. If a miner at the point $ (a,b) $ uses his hook to mine a diamond mine at the point $ (c,d) $ , he will spend $ sqrt{(a-c)2+(b-d)2} $ energy to mine it (the distance between these points). The miners can’t move or help each other.

The object of this game is to minimize the sum of the energy that miners spend. Can you find this minimum?

输入格式

The input consists of multiple test cases. The first line contains a single integer $ t $ ( $ 1le tle 10 $ ) — the number of test cases. The description of the test cases follows.

The first line of each test case contains a single integer $ n $ ( $ 1 le n le 10^5 $ ) — the number of miners and mines.

Each of the next $ 2n $ lines contains two space-separated integers $ x $ ( $ -10^8 le x le 10^8 $ ) and $ y $ ( $ -10^8 le y le 10^8 $ ), which represent the point $ (x,y) $ to describe a miner’s or a diamond mine’s position. Either $ x = 0 $ , meaning there is a miner at the point $ (0, y) $ , or $ y = 0 $ , meaning there is a diamond mine at the point $ (x, 0) $ . There can be multiple miners or diamond mines at the same point.

It is guaranteed that no point is at the origin. It is guaranteed that the number of points on the x-axis is equal to $ n $ and the number of points on the y-axis is equal to $ n $ .

It’s guaranteed that the sum of $ n $ for all test cases does not exceed $ 10^5 $ .

输出格式

For each test case, print a single real number — the minimal sum of energy that should be spent.

Your answer is considered correct if its absolute or relative error does not exceed $ 10^{-9} $ .

Formally, let your answer be $ a $ , and the jury’s answer be $ b $ . Your answer is accepted if and only if $ frac{|a - b|}{max{(1, |b|)}} le 10^{-9} $ .

样例 #1

样例输入 #1

3
2
0 1
1 0
0 -1
-2 0
4
1 0
3 0
-5 0
6 0
0 3
0 1
0 2
0 4
5
3 0
0 4
0 -3
4 0
2 0
1 0
-3 0
0 -10
0 -2
0 -10

样例输出 #1

3.650281539872885
18.061819283610362
32.052255376143336

提示

In the first test case, the miners are at $ (0,1) $ and $ (0,-1) $ , while the diamond mines are at $ (1,0) $ and $ (-2,0) $ . If you arrange the miners to get the diamond mines in the way, shown in the picture, you can get the sum of the energy $ sqrt2 + sqrt5 $ .

思路

这道题是求n矿工和n钻石的欧式距离最短之和
考虑2种情况:

  1. 近对近,远对远
  2. 近对远

证明最有解过程如下:
证明成功

代码实现

#include<bits/stdc++.h>
using namespace std;

const int maxn=1e5+10;
int t,n,cnt1,cnt2;
double ans=0;
struct node{
	double x,y;
}a[maxn],b[maxn];
/*
struct node{
	int x,y;
}b[maxn];
*/
inline bool cmpa(node l,node o){return abs(l.y)<abs(o.y);}
inline bool cmpb(node l,node o){return abs(l.x)<abs(o.x);}
int main(){
	scanf("%d",&t);
	while(t--){
		cnt1=0,cnt2=0,ans=0.0;
		scanf("%d",&n);
		for(int i=1;i<=2*n;i++){
			double u,v;
			scanf("%lf%lf",&u,&v);
			if(u==0){
				a[++cnt1].x=u;
				a[cnt1].y=v;
			}
			else {
				b[++cnt2].x=u;
				b[cnt2].y=v;
			}
		}
		sort(a+1,a+cnt1+1,cmpa);
		sort(b+1,b+cnt2+1,cmpb);
		for(int i=1;i<=n;i++){
			double ans1=sqrt((a[i].x-b[i].x)*(a[i].x-b[i].x)+(a[i].y-b[i].y)*(a[i].y-b[i].y));
			ans+=ans1;
		}
		printf("%.15lfn",ans);
	}
	return 0;
} 

最后

以上就是小巧咖啡豆为你收集整理的CF1495A题解题目思路代码实现的全部内容,希望文章能够帮你解决CF1495A题解题目思路代码实现所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(30)

评论列表共有 0 条评论

立即
投稿
返回
顶部