我是靠谱客的博主 幽默鸡翅,最近开发中收集的这篇文章主要介绍POJ - 3104 Drying(二分),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Drying
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13522 Accepted: 3472

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2
 
题意:有一些衣服,每件衣服有一定水量,有一个烘干机,每次可以烘一件衣服,每分钟可以烘掉k滴水。每件衣服没分钟可以自动蒸发掉一滴水,用烘干机烘衣服时不蒸发。问最少需要多少时间能烘干所有的衣服。
 
假设某件衣服拥有的水量为ki,用二分枚举最小的时间m,那么针对ki < m的衣服,我们就不需要去管,然后就是处理ki >= m的衣服,可以写出一个不等式ki - kx <= m - x,这个不等式中的x表示针对ki滴水滴的衣服用烘干机烘干了多久,对x进行求和判读即可。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
#include <cmath>

using namespace std;
typedef long long LL;
const int MAXN = 1e6 + 5;
LL n, k, ma;
LL A[MAXN];

bool C(LL m) {
	LL res = 0;
	if(k == 1) {
		if(ma > m) return false;
		return true;
	}
	for(int i = 0; i < n; i ++) {
		if(A[i] > m && k > 1) {
			res += (A[i] - m + k - 2) / (k - 1);
		}
		if(res > m) return false;
	}
	return true;
}

int main() {
	while(~scanf("%lld", &n)) {
		ma = 0;
		for(int i = 0; i < n; i ++) {
			scanf("%lld", &A[i]);
			ma = max(ma, A[i]);
		}
		scanf("%lld", &k);
		LL lb = -1, ub = ma;
		while(ub - lb > 1) {
			LL mid = (ub + lb) >> 1;
			if(C(mid)) {
				ub = mid;
			} else {
				lb = mid;
			}
		}
		printf("%dn", ub);
	}
	return 0;
}

最后

以上就是幽默鸡翅为你收集整理的POJ - 3104 Drying(二分)的全部内容,希望文章能够帮你解决POJ - 3104 Drying(二分)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(69)

评论列表共有 0 条评论

立即
投稿
返回
顶部