我是靠谱客的博主 踏实唇彩,最近开发中收集的这篇文章主要介绍B - The Suspects POJ - 1611(并查集),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

B - The Suspects POJ - 1611(并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意:同学之间有一种传染病,在一个小组里如果有一个病人,那么全部人都有病。现在0号有病,问一共多少人有病。

思路:经典的并查集。注意在读入小组成员的时候,5 1 2 3 4 5, 表示5个人1 2 3 4 5是在一个组里,建关系的时候,直接存一下first=1,然后2 3 4 5 分别和first建立关系就好了。

代码:

#include <iostream>
#include <queue>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>

using namespace std;

int pre[30005];
int n,m;

int root( int x )
{
    int i=x,j;
    while ( x!=pre[x] ) {
        x = pre[x];
    }

    while ( i!=x ) {
        j = pre[i];
        pre[i] = x;
        i = j;
    }
    return x;
}

void join( int a, int b )
{
    int x = root(a);
    int y = root(b);
    if ( x!=y ) {
        pre[max(x,y)] = min(x,y); // 大的服从小的,让0永远是大领导,方便统计有多少人是0号感染的
    }
}

int main()
{
    int i,j;
    while ( cin>>n>>m ) {
        if ( n==0 && m==0 ) {
            break ;
        }
        for ( i=0; i<n; i++ ) {
            pre[i] = i;
        }
        int first = -1;
        for ( i=0; i<m; i++ ) {
            int k;
            cin >> k;
            for ( j=0; j<k; j++ ) {
                int x;
                cin >> x;
                if ( j==0 ) {
                    first = x; // 把第一个点存起来
                    continue ;
                }
                join(first,x); // 后面的数都和第一个建立联系
            }
        }
        int ans = 0;
        for ( i=0; i<n; i++ ) {
            if ( root(i)==0 ) {  // 开始写的pre[]==0, 结果wa了
                ans ++;
            }
        }
        cout << ans << endl;
    }

    return 0;
}

最后

以上就是踏实唇彩为你收集整理的B - The Suspects POJ - 1611(并查集)的全部内容,希望文章能够帮你解决B - The Suspects POJ - 1611(并查集)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部