我是靠谱客的博主 潇洒冬日,最近开发中收集的这篇文章主要介绍POJ-1611 The Suspects(并查集),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

POJ-1611 The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

#include <iostream>
#include <cstdio>
using namespace std;
#define MAX 30100
int sum[MAX];   
int fa[MAX];    
int find(int x)    
{
     if(x!=fa[x])                   
     x=find(fa[x]);
     return x;
}
void Union(int x,int y)   
{
     int xn=find(x);
     int yn=find(y);
     if(xn!=yn)
     {
         fa[yn]=xn;          //合并人也交出
         sum[xn]+=sum[yn];  //+sum[yn],是一种记忆化处理,减少重复的计算,所以每一个人只要有关联,他的根就会加上一个人
     }                     //所以初始化为1,就很好理解了
}
int main()
{
     int n,m,i;
     while(scanf("%d%d",&n,&m)!=EOF)
     {
           if(n==0&&m==0)
           break;
           for(i=0;i<n;i++)
           {
              fa[i]=i;
              sum[i]=1;
           }         
           while(m--)
           {                    
             int k,a,b;
             scanf("%d",&k);  
             scanf("%d",&a);
             k--;
             while(k--)
             {
                 scanf("%d",&b);
                 Union(a,b);    
             }
           }
         printf("%dn",sum[find(0)]);//因为根节点不一定就是0。
    }
    return 0;
}

最后

以上就是潇洒冬日为你收集整理的POJ-1611 The Suspects(并查集)的全部内容,希望文章能够帮你解决POJ-1611 The Suspects(并查集)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(36)

评论列表共有 0 条评论

立即
投稿
返回
顶部