概述
原题:
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
题意:
有n个人编号为0至n-1,现在给出m个组,每一个组内有k个人,只要在一个组内就算相互认识,而且只要两个人都认识同一个人就算相互认识,现要求你找出认识编号为0的人的个数。(0本身也算)
题解:
简单并查集问题,只要两个人认识就归并到一个组内,最后找出和0在同一个组内的人即可。(更多细节见代码)
附上AC代码:
//更新于2018/11/7
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int n,m,k,tmp1,tmp2,cnt;
short f[30005],a[30005];
//找到第i个人的祖先
int findf(int i)
{
if(f[i]!=i)
return findf(f[i]);
return f[i];
}
//如果两个人的祖先不一样,合并到一起
void setf(int x,int y)
{
int a=findf(x),b=findf(y);
if(a!=b)
f[b]=a;
}
//初始化
void init()
{
for(int i=0;i<n;++i)
f[i]=i;
cnt=0;
}
//检查有几个人是和第0个人一组的
void check()
{
for(int i=0;i<n;++i)
{
if(findf(i)==findf(0))cnt++;
//cout<<i<<endl;
}
}
//测试过程用的
void test()
{
for(int i=0;i<n;++i)
{
cout<<f[i]<<" ";
if(i%10==9)cout<<endl;
}
}
int main()
{
while(cin>>n>>m)
{
if(n==0&&m==0) break;
init();
for(int i=0;i<m;++i)
{
cin>>k;
if(k>=1)
{
cin>>tmp1;
for(int i=1;i<k;++i)
{
cin>>tmp2;
setf(tmp1,tmp2);
}
}
}
check();
//test();
cout<<cnt<<endl;
}
return 0;
}
欢迎评论!
最后
以上就是老实钢铁侠为你收集整理的POJ-1611-The Suspects(并查集)的全部内容,希望文章能够帮你解决POJ-1611-The Suspects(并查集)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复