我是靠谱客的博主 鲤鱼裙子,最近开发中收集的这篇文章主要介绍ACM--steps--dyx--1.2.4--BuildingsBuildings,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Buildings

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2432 Accepted Submission(s): 1728
 
Problem Description
We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

 
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.
 
Output

            Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
 
Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0
 
Sample Output
2
5
 
 
Source
2008 HZNU Programming Contest
 
Recommend
lcy

#include<iostream>
using namespace std;
int main()
{
int t;//表示测试数据。
int dyx[109][109];
while(cin>>t)
{
while(t--)
{
int sum=0;
int n,m;
cin>>n>>m;//表示地图的行列。
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
cin>>dyx[i][j];
if(dyx[i][j]==1)
sum++;
}
}
cout<<sum<<endl;
}
}
return 0;
}


 

最后

以上就是鲤鱼裙子为你收集整理的ACM--steps--dyx--1.2.4--BuildingsBuildings的全部内容,希望文章能够帮你解决ACM--steps--dyx--1.2.4--BuildingsBuildings所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(62)

评论列表共有 0 条评论

立即
投稿
返回
顶部