我是靠谱客的博主 还单身唇彩,最近开发中收集的这篇文章主要介绍HDU 6153-A Secret(kmp&&ccpc),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell:
Suffix(S2,i) = S2[i…len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li.
Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.

Input
Input contains multiple cases.
The first line contains an integer T,the number of cases.Then following T cases.
Each test case contains two lines.The first line contains a string S1.The second line contains a string S2.
1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.

Output
For each test case,output a single line containing a integer,the answer of test case.
The answer may be very large, so the answer should mod 1e9+7.

Sample Input
2
aaaaa
aa
abababab
aba

Sample Output
13
19
Hint

case 2:
Suffix(S2,1) = “aba”,
Suffix(S2,2) = “ba”,
Suffix(S2,3) = “a”.
N1 = 3,
N2 = 3,
N3 = 4.
L1 = 3,
L2 = 2,
L3 = 1.
ans = (3*3+3*2+4*1)%1000000007.

kmp 拓展 , 网上找的模板, 后面处理就ok

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int mod = 1000000007;
int cnt[1000005];
inline ll Add(ll n)
{
ll m=((n%mod)*((n+1)%mod)/2)%mod;
return m;
}
char t[1000005],p[1000005];
int Next[1000005],ex[1000005];
void pre(char p[])
{
int m=strlen(p);
Next[0]=m;
int j=0,k=1;
while(j+1<m&&p[j]==p[j+1]) j++;
Next[1]=j;
for(int i=2; i<m; i++)
{
int P=Next[k]+k-1;
int L=Next[i-k];
if(i+L<P+1) Next[i]=L;
else
{
j=max(0,P-i+1);
while(i+j<m&&p[i+j]==p[j]) j++;
Next[i]=j;
k=i;
}
}
}
void exkmp(char p[],char t[])
{
int m=strlen(p),n=strlen(t);
pre(p);
int j=0,k=0;
while(j<n&&j<m&&p[j]==t[j]) j++;
ex[0]=j;
for(int i=1;i<n;i++)
{
int P=ex[k]+k-1;
int L=Next[i-k];
if(i+L<P+1) ex[i]=L;
else
{
j=max(0,P-i+1);
while(i+j<n&&j<m&&t[i+j]==p[j]) j++;
ex[i]=j;
k=i;
}
}
}
int main()
{
int ss;
scanf("%d",&ss);
while(ss--)
{
scanf("%s %s",&t,&p);
int Ti=strlen(t);
int Pi=strlen(p);
reverse(t,t+Ti);
reverse(p,p+Pi);
pre(p);
memset(Next, 0,sizeof(Next));
memset(ex, 0, sizeof(ex));
exkmp(p,t);
ll ans=0;
for(int i=0; i<Ti;++i)
{
if(ex[i])
ans=(ans+Add(ex[i])%mod)%mod;
}
printf("%dn",ans%mod);
}
return 0;
}

最后

以上就是还单身唇彩为你收集整理的HDU 6153-A Secret(kmp&&ccpc)的全部内容,希望文章能够帮你解决HDU 6153-A Secret(kmp&&ccpc)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(46)

评论列表共有 0 条评论

立即
投稿
返回
顶部