概述
Picture
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 16345 Accepted Submission(s): 8465
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+ | | | | +---+
代码:
#include<stdio.h>
int main()
{
int i,j,n,m;
char a[100];
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=m+2;i++)
{
for(j=1;j<=n+2;j++)
{
if((i==1&&j==1)||(i==1&&j==n+2)||(i==m+2&&j==1)||(i==m+2&&j==n+2))
printf("+");
else if(i==1||i==m+2)
printf("-");
else if(j==1||j==n+2)
printf("|");
else
printf(" ");
}
printf("n");
}
printf("n");
}
return 0;
}
最后
以上就是陶醉长颈鹿为你收集整理的hdu2052PicturePicture的全部内容,希望文章能够帮你解决hdu2052PicturePicture所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复