我是靠谱客的博主 独特微笑,最近开发中收集的这篇文章主要介绍hdu 5587 Array Array,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 255    Accepted Submission(s): 133


Problem Description
Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
 

Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases. (1T2103)
Next T line contains, each line contains one interger M.  (1M1016)
 

Output
For each test case,output the answer in a line.
 

Sample Input

3 1 3 5
 

Sample Output

1 4 7
 

Source
BestCoder Round #64 (div.2)
 
题目大意:
Vicky是个热爱数学的魔法师,拥有复制创造的能力。
一开始他拥有一个数列{1}。每过一天,他将他当天的数列复制一遍,放在数列尾,并在两个数列间用0隔开。Vicky想做些改变,于是他将当天新产生的所有数字(包括0)全加1。Vicky现在想考考你,经过100天后,这个数列的前M项和是多少?。
解题思路:
先打个表,不可能达到 100天,因为最大是10^16次方的和。。。
然后推一下每个0也就是 1 的值就行了。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
#define MM(a) memset(a,0,sizeof(a))
typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 65;
const int mod = 1e9+7;
const double eps = 1e-10;
const int INF = 0x3f3f3f3f;
LL gcd(LL a, LL b)
{
if(b == 0)
return a;
return gcd(b, a%b);
}
LL sum[maxn];
void Init()///每一个0的值
{
sum[0] = 1;
LL tmp = 1;
for(int i=1; i<maxn; i++)///10^16次方最多不超过60天
{
sum[i] = (sum[i-1]-1)*2+tmp+1;
tmp *= 2;
}
}
int main()
{
Init();
//
for(int i=0; i<63; i++)
//
cout<<sum[i]<<" ";
int T;
cin>>T;
while(T--)
{
LL m;
cin>>m;
LL ret, tmp, x, y;
ret = x = tmp = 0;
y = 1;
while(m)
{
if(m%2)
{
ret += sum[tmp]+x;
x += y;
///cout<<ret<<endl;
}
y<<=1;
tmp++;
m>>=1;
}
cout<<ret<<endl;
}
return 0;
}


最后

以上就是独特微笑为你收集整理的hdu 5587 Array Array的全部内容,希望文章能够帮你解决hdu 5587 Array Array所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(49)

评论列表共有 0 条评论

立即
投稿
返回
顶部