我是靠谱客的博主 简单冰淇淋,最近开发中收集的这篇文章主要介绍Hdoj 1698 Just a Hook,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

Source
2008 “Sunline Cup” National Invitational Contest


题目分析
因为涉及到很多区间的修改,用线段树即可,基本是按照模板写就可以了
Code

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cctype> 
#include<cstring>
#include<cstdlib>
#include<vector>
using namespace std;
typedef __int64 ll;
const int MAXN = 400000;
int sum;
struct node
{
int l,r,num;
}tree[MAXN];
void buildTree(int i,int l,int r)
{
tree[i].l = l; tree[i].r = r; tree[i].num = 1; //默认值为1 
if(l==r) return;
else
{
int mid = (l+r)/2;
buildTree(i*2,l,mid);
buildTree(i*2+1,mid+1,r);
} //递归建树 
}
void updateTree(int i,int l,int r,int num)
{
if(l==tree[i].l && r==tree[i].r)
{
tree[i].num = num;
return;
}
if(num==tree[i].num) return; //若较大的区间已经是同样的num就可以直接退出了 
if(0<tree[i].num)
{
tree[i*2].num = tree[i*2+1].num = tree[i].num;
tree[i].num=0;
}
int mid=(tree[i].l+tree[i].r)/2;
if(r<=mid)
updateTree(i*2,l,r,num);
else if(l>mid) updateTree(i*2+1,l,r,num);
else {
updateTree(i*2,l,mid,num);
updateTree(i*2+1,mid+1,r,num);
}
}
void calSum(int i,int l,int r)
{
if(tree[i].num>0)
{
sum += (tree[i].r-tree[i].l+1)*tree[i].num;
return;
}
else
{
int mid = (tree[i].l+tree[i].r)/2;
if(r<=mid) calSum(i*2,l,r);
else if(l>mid) calSum(i*2+1,l,r);
else {
calSum(i*2,l,mid);
calSum(i*2+1,mid+1,r);
}
}
}
int main()
{
int t;
cin >> t;
int cnt = 0;
while(t--)
{
int n,len;
cin >> len; cin >> n;
buildTree(1,1,len);
for(int i=1;i<=n;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c); //这里用cin就超时了.... 
updateTree(1,a,b,c);
}
sum = 0;
calSum(1,1,len);
cnt++;
printf("Case %d: The total value of the hook is %d.n",cnt,sum);
}
return 0 ;
}

更多问题请关注个人博客,不定时更新

最后

以上就是简单冰淇淋为你收集整理的Hdoj 1698 Just a Hook的全部内容,希望文章能够帮你解决Hdoj 1698 Just a Hook所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(51)

评论列表共有 0 条评论

立即
投稿
返回
顶部