我是靠谱客的博主 内向麦片,最近开发中收集的这篇文章主要介绍L1-039. 古风排版L1-039. 古风排版,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

L1-039. 古风排版

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)

输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
ce s

提交代码


坑就在于后面的换行符


# include <iostream>

# include <algorithm>
# include <set>
# include <map>
# include <vector>
# include <queue>
# include <numeric>
# include <string>
# include <cstring>
# include <iomanip> 
# include <cstdio>
//# include <bits/stdc++.h>
using namespace std;  
int main()  
{  
    int n,m;  
    char s[1001],a[101][1001];  
    scanf("%d",&n);  
    getchar();  
    gets(s);  
    int l=strlen(s),t=0;  
 //   m=(l+n-1)/n;///和下面两行一样的效果  
    m=l/n; 
    if(l%n!=0) m++; 
    for(int j=m-1;j>=0;j--)  
    {  
        for(int i=0;i<n;i++)  
        {  
            if(t<l) a[i][j]=s[t++];  
            else a[i][j]=' ';///不足的补空格  
        }  
    }  
//4个一组
    for(int j=0;j<n;j++)  
    {  
        for(int i=0;i<m;i++)  
            cout << a[j][i];
        printf("n");  
    }  
    return 0;  
}

最后

以上就是内向麦片为你收集整理的L1-039. 古风排版L1-039. 古风排版的全部内容,希望文章能够帮你解决L1-039. 古风排版L1-039. 古风排版所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部