我是靠谱客的博主 娇气小伙,最近开发中收集的这篇文章主要介绍算法笔记-问题 A: Fibonacci,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

问题 A: Fibonacci

题目描述

The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55...} are defined by the recurrence: 
F0=0 F1=1 Fn=Fn-1+Fn-2,n>=2 
Write a program to calculate the Fibonacci Numbers.

输入

Each case contains a number n and you are expected to calculate Fn.(0<=n<=30) 。

输出

For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入 Copy

1

样例输出 Copy

1

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 31;
int d[maxn];
int F(int n){
if(n==0||n==1) return 1;
if(d[n]!=-1) return d[n];
else{
d[n] = F(n-1) + F(n-2);
return d[n];
}
}
int main(){
fill(d, d+maxn, -1);
int n;
while(scanf("%d", &n)!=EOF){
printf("%dn", F(n-1));
}
return 0;
}

 

最后

以上就是娇气小伙为你收集整理的算法笔记-问题 A: Fibonacci的全部内容,希望文章能够帮你解决算法笔记-问题 A: Fibonacci所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(44)

评论列表共有 0 条评论

立即
投稿
返回
顶部