我是靠谱客的博主 迷路树叶,最近开发中收集的这篇文章主要介绍POJ To the Max,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7
0
9
2 -6
2
-4 1 -4
1
-1 8
0 -2

Sample Output

15
从左上到右下,依次求最大和中的最大值就是答案;
LANGUAGE:C
CODE:

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
#define maxn 101
int maxsum(int num[],int n)
{//求那母数组的最大连续和
int max=0,sum=0,i;
for(i=0;i<n;i++)
{
if(sum>=0)sum+=num[i];
else sum=num[i];
if(sum>max)max=sum;
}
return max;
}
int main()
{
//freopen("in.txt","r",stdin);
int n,matrix[maxn][maxn],sum[maxn];
int i,j,k,t,max;
scanf("%d",&n);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&matrix[i][j]);
max=matrix[0][0];
for(i=0; i<n; i++)
{
memset(sum,0,sizeof(sum));
for(j=i; j<n; j++)
{//从I到N层
for(k=0; k<n; k++)
{//SUM计算纵向的和
sum[k]+=matrix[j][k];
}
t=maxsum(sum,n);//纵向和的最大和
if(t>max)max=t;
}
}
printf("%dn",max);
return
0;
}


最后

以上就是迷路树叶为你收集整理的POJ To the Max的全部内容,希望文章能够帮你解决POJ To the Max所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部