我是靠谱客的博主 雪白大叔,最近开发中收集的这篇文章主要介绍动态规划习题 poj1050,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

原题:
To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31305 Accepted: 16272

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4
1 -1
8
0 -2

Sample Output

解题思路:dp

代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int num;
int states[100][100];
int input[100];
int main()
{
int max = -127;
cin>>num;
memset(states, 0, sizeof(states));
for(int n=0; n<num; n++)
{
for(int x=0; x<num; x++)
cin>>input[x];
for(int i=0; i<num; i++)
{
int sum = 0;
for(int j=i; j<num; j++)
{
sum += input[j];
states[i][j] = states[i][j]+sum > sum ? states[i][j]+sum : sum;
max = max >= states[i][j] ? max : states[i][j];
}
}
}
cout<<max<<endl;
return 0;
}

 

 

转载于:https://www.cnblogs.com/tianji/archive/2012/05/19/2508842.html

最后

以上就是雪白大叔为你收集整理的动态规划习题 poj1050的全部内容,希望文章能够帮你解决动态规划习题 poj1050所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(35)

评论列表共有 0 条评论

立即
投稿
返回
顶部