概述
用户输入一个数字序列,然后显示该序列中的不同数字。该序列以“0”为结束标记,0以后的数字不计入统计,而且0也不计入统计。
裁判测试程序样例:
在这里给出部分代码,请完善代码,实现功能。
import java.util.ArrayList;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
ArrayList<Integer> list = new ArrayList<Integer>();
/* 请在这里填写答案 */
for(int i = 0; i < list.size(); i++)
System.out.print(list.get(i) + " ");
}
}
输入样例:
在这里给出一组输入。例如:
1 3 5 7 1 3 5 7 2 0
输出样例:
在这里给出相应的输出。例如:
1 3 5 7 2
//法一
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
while(n != 0 ) {
list.add(n);
n = sc.nextInt();
}
for (int i = 0; i < list.size(); i ++) {
for (int j = 0; j < list.size(); j ++) {
if(list.get(i) == list.get(j) && i != j) {
list.remove(j);
j = 0;//这一步一定不能省,如果省了j就一直++,此时有连续多个相同元素则会报错
}
}
}
sc.close();
//法二
Scanner sc=new Scanner(System.in);
int n = sc.nextInt();;
while(n!=0){
if(!list.contains(n)) {
list.add(n);
}
n=sc.nextInt();
}
sc.close();
最后
以上就是和谐蜻蜓为你收集整理的6-7 筛选数字 (10分)pta_java的全部内容,希望文章能够帮你解决6-7 筛选数字 (10分)pta_java所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复