概述
描述
One measure of "unsortedness" in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence "DAABEC", this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence "AACEDGG" has only one inversion (E and D)--it is nearly sorted--while the sequence "ZWQM" has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of "sortedness", from "most sorted" to "least sorted". All the strings are of the same length.
输入
The first line contains two integers: a positive integer n (0 < n ≤ 50) giving the length of the strings; and a positive integer m (1 < m ≤ 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
输出
Output the list of input strings, arranged from "most sorted" to "least sorted". If two or more strings are equally sorted, list them in the same order they are in the input.
样例输入
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
样例输出
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct str
{
char a[100];
int n;
}q[100];
int cmp(const str a,const str b)
{
return a.n<b.n;
}
int sum(char a[])
{
int i,j,sum=0;
for(i=0;i<strlen(a);i++)
for(j=i+1;j<strlen(a);j++)
if(a[i]>a[j])sum++;
return sum;
}
int main()
{
int n,m;
while(cin>>n>>m)
{
for(int i=0;i<m;i++)
{
cin>>q[i].a;
q[i].n=sum(q[i].a);
}
sort(q,q+m,cmp);
for(int i=0;i<m;i++)
cout<<q[i].a<<endl;
}
return 0;
}
最后
以上就是优雅百合为你收集整理的DNA Sorting的全部内容,希望文章能够帮你解决DNA Sorting所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复