我是靠谱客的博主 霸气白开水,最近开发中收集的这篇文章主要介绍HDOJ 1004 java代码实现--引用相等要用 equals()Let the Balloon Rise,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目链接: 点击打开链接
题目大意:求输入的n个字符串,数量最多的一共字符串。
本人第一次做,由于判断字符串是否相等,使用==判断,导致一直不对,后面查阅书本得知,引用需使用equals()方法判断,方AC

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 119180    Accepted Submission(s): 46715


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink
具体代码实现:
import java.util.*;
class Main{
public static void main(String args[]){
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int n=sc.nextInt();
String str[]=new String[n];
int a[]=new int[n];
//该数组用于存放从该位置之后,一共有多少个字符串与该位置的字符串相同
for(int i=0;i<n;i++){
a[i]=0;
}
if(n==0){
break;
}
for(int i=0;i<n;i++){
str[i]=sc.next();
}
for(int i=0;i<n;i++){
for(int j=i+1;j<n;j++){;
if(str[i].equals(str[j])){
//因为这里的str[]是引用/所以不能直接用==判断
a[i]++;
}
}
}
int t=0;
for(int i=0;i<n;i++){
if(a[i]>a[t]){
t=i;
//找到最大的那个就是最多
}
}
System.out.println(str[t]);
}
}
}

最后

以上就是霸气白开水为你收集整理的HDOJ 1004 java代码实现--引用相等要用 equals()Let the Balloon Rise的全部内容,希望文章能够帮你解决HDOJ 1004 java代码实现--引用相等要用 equals()Let the Balloon Rise所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(60)

评论列表共有 0 条评论

立即
投稿
返回
顶部