概述
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3
Sample Output
19
18
10
-17
-14
-4
AC代码:
#include <stdio.h>
#include <iostream>
using namespace std;
int f(char x) {
if (x >= 'a'&&x <= 'z') { //a~z = -1~-26 ASCII:a=97
return -(x - 96);
}
if (x >= 'A'&&x <= 'Z') { //A~Z = 1~26 ASCII:A=65
return x - 64;
}
}
int main() {
int t, y;
char x;
cin >> t;
while (t--) {
cin >> x >> y;
int k = f(x) + y;
cout << k << endl;
}
return 0;
}
最后
以上就是独特小刺猬为你收集整理的杭电oj2055的全部内容,希望文章能够帮你解决杭电oj2055所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复