概述
I was trying to solve problem '1234 - Harmonic Number', I wrote the following code
long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n < 231).
Output
For each case, print the case number and H(n) calculated by the code.
Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
题意:
让我们求f(n)=n/1+n/2+n/3+......+n/n;同时注意n/i取整;
第一种:
首先我们先看数据的范围,n (1 ≤ n < 2 31),数据范围太大,如果我们按照题目中的代码直接暴力肯定超时,那么,我们就要优化代码;
f=n/x这个函数关于y = x 对称对称点刚好是sqrt(n),于是就简单了直接求sum+n/i (i*i<n && i >=1),然后乘以2,再减去i*i即可。
当n==10时,m=sqrt(10)==13,f(10)==(10+5+3)*2-3*3=27;
关于m对称,左右相差m*m,左边10+5+3=18,右边2+2+1+1+1+1+1=9,和左边相差3*3=9,
故,这道题我们就可以简化了;
公式:
m=sqrt(n);
f(n)=(n/1+n/2+n/3+......+n/k)*2-m*m;(n/k<=m);
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
typedef long long ll;
using namespace std;
int main()
{
int t,k=1;
ll n;
scanf("%d",&t);
for(int i=0; i<t; i++)
{
scanf("%lld",&n);
ll res=0;
int m=sqrt(n);
for(int i=1; i<=m; i++)
res+=n/i;
res*=2; ///找规律
res-=m*m;
printf("Case %d: %lldn",k++,res);
}
return 0;
}
第二种:
假设 tmp 是 n/i 的值,当n == 10的时候(取具体值) 当 tmp = 1 时,个数 是10/1 - 10/2 == 5个
当 tmp = 2 时,个数 是10/2 - 10/3 == 2个
当 tmp = 3 时,个数 是10/3 - 10/4 == 1个 ………… 当 tmp = 10时,个数是10/10 - 10/11 == 1个 所以我们发现有个规律了,当tmp == i 的时候,我们要求的个数就是 10/i - 10/(i+1),然后我们前1 — sqrt(n)个数的数值还是比较大的,但是数据范围变小了 暴力可以求出来,剩下的 sqrt(n)+1 — n个数中 数据范围还是比较大,但是 n/i 的数据范围介于 1 - sqrt(n)之间,所以用我们找出的规律可以求出来,我们只需要 两个for循环就搞定了,时间复杂度 O(sqrt(n)),
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
typedef long long ll;
using namespace std;
ll h(ll n)
{
ll res=0;
int m=sqrt(n);
for(int i=1;i<=m;i++)
res+=n/i;
for(int i=1;i<=m;i++)
res+=(n/i-n/(i+1))*i;
if(m==n/m)
res-=m;
return res;
}
int main()
{
int t,k=1;
ll n;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
scanf("%lld",&n);
printf("Case %d: %lldn",k++,h(n));
}
return 0;
}
世界上没有所谓的天才,就像鲁迅说的那样:“哪里有天才,我是把别人喝咖啡的功夫,都用在工作上。”
每天努力那么一点点,不要做语言上的巨人,行动上的矮子;
也不要奢望进步会立竿见影,每天只需努力一点点,进步一点点就好。
最后
以上就是会撒娇白羊为你收集整理的Harmonic Number (II) 谐波级次的全部内容,希望文章能够帮你解决Harmonic Number (II) 谐波级次所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复