概述
//
Problem C: 【C++ 字符串】替换字符串中的字符
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 1003 Solved: 537
[Submit][Status][Web Board]
Description
Write a program to input several strings from the keyboard and replace each space in these string with the character '@'.
Input
输入有多行,第一行输入一个整数N,后面N行每行输入一个字符串,以‘#’为定界符表示字符串结束
Output
输出有N行,每行输出一个替换字符后的字符串
Sample Input
3
A cat#
a b c#
a #
Sample Output
A@cat
a@b@c
a@@@
HINT
注意:输入N后和每个字符串后的回车符的处理
//
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s; int n;
while( cin>>n )
{
cin.get();
while( n-- )
{
getline( cin,s );
for( auto i:s )
if( i=='#' ) break;
else if( i==' ' ) cout<<'@';
else cout<<i;
cout<<endl;
}
}
return 0;
}
最后
以上就是细腻大神为你收集整理的UJN_1682 【C++ 字符串】替换字符串中的字符的全部内容,希望文章能够帮你解决UJN_1682 【C++ 字符串】替换字符串中的字符所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复