概述
We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex
Input
There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.
Output
For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.
Sample Input
4 1
90 90 90 90
6 1
60 60 60 60 60 60
Sample Output
2.000
2.598
n边形的面积可以拆分成n个三角形面积之和
而已知每个三角形的两边及两边夹角,我们可以通过三角形面积公式算出每个三角形的面积,相加之和便是最终的n边形面积
水题,直接求所有三角形的面积即可 一开始想复杂了,即使是有角度大于180的也不需要分开考虑,应为此时sin为负就相当于对面积进行减了
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
int n,d,i,x;
double ans;
while(~scanf("%d%d",&n,&d))
{
ans=0;
for(i=0;i<n;i++)
{
scanf("%d",&x);
ans+=d*d*sin(PI*x/180)/2;
}
printf("%.3fn",ans);
}
return 0;
}
最后
以上就是清秀龙猫为你收集整理的2016 ICPC大连赛区 [Cloned] I - Convex的全部内容,希望文章能够帮你解决2016 ICPC大连赛区 [Cloned] I - Convex所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复