我是靠谱客的博主 缓慢大象,最近开发中收集的这篇文章主要介绍ACM-ICPC 2018 南京赛区网络预赛 签到水题,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

A An Olympian Math Problem

  •  1000ms
  •  65536K

Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k!=1×2×⋯×(k−1)×k

We denote S:

S=1×1!+2×2!+⋯+(n−1)×(n−1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer n.

It is guaranteed that 2≤n≤10^18.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: S=1×1!=1, and 1 modulo 2 is 1.

The second test is: S=1×1!+2×2!=5 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2

题目来源

ACM-ICPC 2018 南京赛区网络预赛

 

S = 1×1!+2×2!+⋯+(n−1)×(n−1)!

(n-1)*(n-1)!+(n-2)*(n-2)!=(n-2)!*(n-n-1)(mod n)=(n-2)!*(n-1)(注 -1%n=n-1)......

可得 S = n-1 

 

#include <cstdio>

int main()
{
    int t;
    long long n;
    
    scanf("%d",&t);
    while(t--){
        scanf("%lld",&n);
        printf("%lldn",n-1);
    }
    
    return 0;
}

 

最后

以上就是缓慢大象为你收集整理的ACM-ICPC 2018 南京赛区网络预赛 签到水题的全部内容,希望文章能够帮你解决ACM-ICPC 2018 南京赛区网络预赛 签到水题所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(49)

评论列表共有 0 条评论

立即
投稿
返回
顶部