我是靠谱客的博主 呆萌篮球,最近开发中收集的这篇文章主要介绍Twice Equation,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

问题 L: Twice Equation

时间限制: 1 Sec   内存限制: 128 MB
提交: 50   解决: 25
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

For given L, find the smallest n no smaller than L for which there exists an positive integer m for which 2m(m + 1) = n(n + 1).

输入

This problem contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T < 1000) followed  by T input lines. Each line contains an integer L (1 ≤ L < 10190 ).

输出

For each given L, output the smallest n. If available n does not exist, output −1.

样例输入

3

1

4

21

样例输出

3

20
119

import java.math.*;
import java.util.*;
public class Main {

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);

BigInteger[] daan = new BigInteger[1010];
daan[1] = BigInteger.valueOf(3);
daan[2] = BigInteger.valueOf(20);

BigInteger s[] = new BigInteger[2];
s[0] = BigInteger.valueOf(6);
s[1] = BigInteger.valueOf(2);

for(int i=3; i<=1000; i++)
{
daan[i] = daan[i-1].multiply(s[0]);
daan[i] = daan[i].subtract(daan[i-2]);
daan[i] = daan[i].add(s[1]);
}
int qwe = 0;
int t = input.nextInt();
while(t>0)
{
BigInteger x = input.nextBigInteger();
for(int j=1; j<=310; j++)///190次幂开6次方就大约是310组答案
{
if(x.compareTo(daan[j])<0)
{
qwe = 1;
System.out.println(daan[j]);
break;
}
else if(j == 310 && qwe == 0)
{
System.out.println(-1);
}
}
t=t-1;
}
}
}

最后

以上就是呆萌篮球为你收集整理的Twice Equation的全部内容,希望文章能够帮你解决Twice Equation所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(44)

评论列表共有 0 条评论

立即
投稿
返回
顶部