概述
问题 L: Twice Equation
时间限制: 1 Sec 内存限制: 128 MB提交: 50 解决: 25
[ 提交][ 状态][ 讨论版][命题人: admin]
题目描述
输入
输出
样例输入
3
1
4
21
样例输出
3
20
119
import java.math.*;
import java.util.*;
public class Main {
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);
BigInteger[] daan = new BigInteger[1010];
daan[1] = BigInteger.valueOf(3);
daan[2] = BigInteger.valueOf(20);
BigInteger s[] = new BigInteger[2];
s[0] = BigInteger.valueOf(6);
s[1] = BigInteger.valueOf(2);
for(int i=3; i<=1000; i++)
{
daan[i] = daan[i-1].multiply(s[0]);
daan[i] = daan[i].subtract(daan[i-2]);
daan[i] = daan[i].add(s[1]);
}
int qwe = 0;
int t = input.nextInt();
while(t>0)
{
BigInteger x = input.nextBigInteger();
for(int j=1; j<=310; j++)///190次幂开6次方就大约是310组答案
{
if(x.compareTo(daan[j])<0)
{
qwe = 1;
System.out.println(daan[j]);
break;
}
else if(j == 310 && qwe == 0)
{
System.out.println(-1);
}
}
t=t-1;
}
}
}
最后
以上就是呆萌篮球为你收集整理的Twice Equation的全部内容,希望文章能够帮你解决Twice Equation所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复