概述
Description
Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.
Input
Input starts with an integer T (≤ 20000), denoting the number of test cases.
Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.
Output
For each case, print the case number and the desired result.
Sample Input
2
365
669
Sample Output
Case 1: 22
Case 2: 30
证明:可以根据抽屉原理
也可以这样:
设p(i)表示教室有i个人,但是没有人同时生日的概率
则:p(1)=1
i>1时:第一个人有365种选择,第2个人只有364种选择,第3个人有363种选择...
则:p(i)=(365/365)*(364/365)*(363/365)*...*((365-i+1)/365)
=(265*364*...*(366-i))/(365^i)
则当p(i)<=0.5时,至少2个人同时生日的概率为1-p(i)>=0.5
经过计算:当i=23时,p(23)<=0.5
这道题的题意:如果一年不是有365天呢?
给出n,表示一年有n天,求一个人至少邀请多少个人,才可以至少有2个人同时生日的概率>=0.5
注意:
1.邀请多少个人,所以p(i)<=0.5后,输出的是i-1
2.如果一年只有1天的话,需要邀请1个人。
由于当n=10^5的时候,i只比300多一点,所以在循环的时候,直接i<=400
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const double eps=1e-8;
int main()
{
int t, n, ncase=1;
scanf("%d", &t);
while(t--)
{
scanf("%d",&n);
if(n==1)
{
printf("Case %d: 1n",ncase++);
continue;
}
double p=1.0;
for(int i=1; i<=400; i++)
{
p*=(1.0)*(n-i)/(1.0*n);
if(p<=0.5)
{
printf("Case %d: %dn",ncase++,i);
break;
}
}
}
return 0;
}
最后
以上就是结实毛巾为你收集整理的light oj 1104的全部内容,希望文章能够帮你解决light oj 1104所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复