我是靠谱客的博主 疯狂小鸽子,最近开发中收集的这篇文章主要介绍Ekka Dokka LightOJ 1116简单数学,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that’s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output
For each case, print the case number first. After that print “Impossible” if they can’t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input
3

10

5

12

Sample Output
Case 1: 5 2

Case 2: Impossible

Case 3: 3 4


题意:将 W W 写成 W=NM W = N ∗ M 的形式,其中 N N 是奇数,M是偶数, M M 要最小的,如果不能够写成这种形式,输出Impossible
由算数基本定理可以得到

W=2apa11pa22pa33pann W = 2 a ∗ p 1 a 1 ∗ p 2 a 2 ∗ p 3 a 3 ⋯ ∗ p n a n

因为质数除了2之外,其他的全部是奇数
所以
M=2a M = 2 a

N=pa11pa22pa33pann=W2a N = p 1 a 1 ∗ p 2 a 2 ∗ p 3 a 3 ⋯ ∗ p n a n = W 2 a

a=0 a = 0 的时候 M M 不存在,输出Impossible
基本思路就是这样


code:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
int t;
cin>>t;
for(int k=1;k<=t;k++)
{
ll n=1,m=1;
ll w;
scanf("%lld",&w);
if(w%2==0)
{
while(w%2==0)
{
n*=2;
w/=2;
}
printf("Case %d: %lld %lldn",k,w,n);
}
else
printf("Case %d: Impossiblen",k);
}
return 0;
}

最后

以上就是疯狂小鸽子为你收集整理的Ekka Dokka LightOJ 1116简单数学的全部内容,希望文章能够帮你解决Ekka Dokka LightOJ 1116简单数学所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部