概述
Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9916 Accepted: 3302
Description
Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.
Input
There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.
Note: Wshxzt starts at Node 1.
Output
For each test case, output the maximal numbers of apples Wshxzt can eat at a line.
Sample Input
2 1
0 11
1 2
3 2
0 1 2
1 2
1 3
Sample Output
11
2
Source
POJ Contest,Author:magicpig@ZSU
dp[root][j][0] = max( dp[root][j][0], dp[root][j-l][0]+dp[k][l-2][0] );
表示是原值较大还是从其他子树回到根结点 + 从当前子树k回到根结点的价值较大
dp[root][j][1] = max( dp[root][j][1], dp[root][j-l][0]+dp[k][l-1][1] );
dp[root][j][1] = max( dp[root][j][1], dp[root][j-l][1]+dp[k][l-2][0] );
两个是比较从其他子树回到根+k结点不回来的价值大还是从k结点回到根+其他子树不回来的价值大
#include "cstring"
#include "string.h"
#include "iostream"
#include "cstdio"
using namespace std;
int n,k;
int dp[105][205][2];
int num[105];
int len=0;
int head[105];
struct edge
{
int now,next;
}edge[205];
void addEdge(int a,int b)
{
edge[len].now=b;
edge[len].next=head[a];
head[a]=len++;
}
void dfs(int root,int last)
{
for(int i=head[root];i!=-1;i=edge[i].next)
{
int temp=edge[i].now;
if(temp==last)
continue;
dfs(temp,root);
for(int j=k;j>=0;j--)
{
if(j!=0)
dp[root][j][1]=max(dp[root][j][1],dp[root][j-1][0]+dp[temp][0][1]);
for(int m=1;j-m>=0;m++)
{
dp[root][j][0]=max(dp[root][j][0],dp[root][j-m][0]+dp[temp][m-2][0]);
//cout<<"m "<<m-2<<endl;
dp[root][j][1]=max(dp[root][j][1],dp[root][j-m][0]+dp[temp][m-1][1]);
dp[root][j][1]=max(dp[root][j][1],dp[root][j-m][1]+dp[temp][m-2][0]);
}
}
}
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
memset(dp,0, sizeof(dp));
memset(head,-1,sizeof(head));
len=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&num[i]);
for(int j=0;j<=k;j++)
dp[i][j][0] = dp[i][j][1] = num[i];
}
for(int i=1;i<=n-1;i++)
{
int a,b;
scanf("%d%d",&a,&b);
addEdge(a,b);
addEdge(b,a);
}
dfs(1,0);
printf("%dn",max(dp[1][k][0],dp[1][k][1]));
}
}
最后
以上就是复杂金毛为你收集整理的POJ 2486 Apple Tree (树形DP)的全部内容,希望文章能够帮你解决POJ 2486 Apple Tree (树形DP)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复