我是靠谱客的博主 心灵美长颈鹿,最近开发中收集的这篇文章主要介绍nyoj546 多重背包,有优化,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Divideing Jewels

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入
Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000.
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line.
输出
For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.
样例输入
1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0
样例输出
#1:Can't be divided.
#2:Can be divided.

题目大意是问有面值1-10的珍珠各有一定数量,问能均分成两份价值一样的吗。

解题思路

  比较明显的多重背包,求出总价值/2,看这些珍珠能不能装满价值为sum/2的背包,利用一个多重背包的计数可以避免三次循环,因为要把i个价值相同的合并成一个物品放入

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[100005];
int count[100005];
int main(){
int a[12];
bool f=true;
int test=1;
while(true){
f=false;
int sum=0;
for (int i=1;i<=10;i++){
cin>>a[i];
if (a[i]!=0) f=true;
sum+=(a[i]*i);
}
if(!f) break;
if (sum%2!=0){
printf("#%d:Can't be divided.nn",test++);
continue;
}
//cout<<sum<<endl;
sum=sum/2;
memset(dp,0,sizeof(dp));
dp[0]=1;
for (int i=1;i<=10;i++){
if (a[i]==0) continue;
memset(count,0,sizeof(count));
for (int j=i;j<=sum;j++){
//一定要先判断dp[j]==0,如果等于1就不用消耗当前面值
count计数用了多少个
if (dp[j]==0&&dp[j-i]==1&&count[j-i]+1<=a[i]){
dp[j]=1;
count[j]=count[j-i]+1;
}
}
}
if (dp[sum]==1)
printf("#%d:Can be divided.nn",test++);
else
printf("#%d:Can't be divided.nn",test++);
//cout<<endl;
}
cout<<endl;
} 




最后

以上就是心灵美长颈鹿为你收集整理的nyoj546 多重背包,有优化的全部内容,希望文章能够帮你解决nyoj546 多重背包,有优化所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(57)

评论列表共有 0 条评论

立即
投稿
返回
顶部