我是靠谱客的博主 贪玩音响,最近开发中收集的这篇文章主要介绍PAT甲级1028 1028. List Sorting (25),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

1028. List Sorting (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

#include<cstdio>
#include<iostream>
#include<string.h>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct student
{
	char ID[20], name[20];
	int score;
};
bool cmp1(student s1, student s2)
{
	return strcmp(s1.ID, s2.ID)<=0;
}
bool cmp2(student s1, student s2)
{
	if (strcmp(s1.name, s2.name)!=0)
	{
		if (strcmp(s1.name, s2.name) < 0)
			return true;
		else
			return false;
	}
	else
		return strcmp(s1.ID, s2.ID) <= 0;//比较器返回的是true或false,必须这样写
}
bool cmp3(student s1, student s2)
{
	if (s1.score != s2.score)
		return s1.score < s2.score;
	else
		return strcmp(s1.ID, s2.ID) <= 0;
}
int main()
{
	int N, C;
	vector<student> v;
	student s;
	cin >> N >> C;
	for (int i = 0; i < N; i++)
	{
		//cin >> s.ID >> s.name >> s.score;
		scanf("%s %s %d", s.ID, s.name,&s.score);
		v.push_back(s);
	}
	switch (C)
	{
	case 1:sort(v.begin(), v.end(), cmp1); break;
	case 2:sort(v.begin(), v.end(), cmp2); break;
	case 3:sort(v.begin(), v.end(), cmp3); break;
	default:
		break;
	}
	for (int i = 0; i < v.size(); i++)
	{
		//cout << v[i].ID << " " << v[i].name << " " << v[i].score << endl;
		printf("%s %s %dn", v[i].ID, v[i].name, v[i].score);
	}
	return 0;
}

最后

以上就是贪玩音响为你收集整理的PAT甲级1028 1028. List Sorting (25)的全部内容,希望文章能够帮你解决PAT甲级1028 1028. List Sorting (25)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部