概述
文章目录
- String Task
- 题面翻译
- 题目描述
- 输入格式
- 输出格式
- 样例 #1
- 样例输入 #1
- 样例输出 #1
- 样例 #2
- 样例输入 #2
- 样例输出 #2
- 样例 #3
- 样例输入 #3
- 样例输出 #3
- 代码
- 小白代码
- 大神代码
- 分析
- 总结
String Task
题面翻译
给出一个长度为 n n n 的单词,写出一个程序,执行以下操作:
- 删除单词里的元音字母。
- 辅音字母前加上字符
.
。 - 所有大写字母全部转化为小写字母。
注:元音字母有 A,O,Y,E,U,I text{A,O,Y,E,U,I} A,O,Y,E,U,I,其余的全部都是辅音字母。
输入仅一行,为一个单词(仅包含大小写字母)。
输出仅一行,代表经程序处理后的单词。
数据范围: 1 ⩽ n ⩽ 100 1leqslant nleqslant 100 1⩽n⩽100。
题目描述
Petya started to attend programming lessons. On the first lesson his task was to write a simple program. The program was supposed to do the following: in the given string, consisting if uppercase and lowercase Latin letters, it:
- deletes all the vowels,
- inserts a character “.” before each consonant,
- replaces all uppercase consonants with corresponding lowercase ones.
Vowels are letters “A”, “O”, “Y”, “E”, “U”, “I”, and the rest are consonants. The program’s input is exactly one string, it should return the output as a single string, resulting after the program’s processing the initial string.
Help Petya cope with this easy task.
输入格式
The first line represents input string of Petya’s program. This string only consists of uppercase and lowercase Latin letters and its length is from $ 1 $ to $ 100 $ , inclusive.
输出格式
Print the resulting string. It is guaranteed that this string is not empty.
样例 #1
样例输入 #1
tour
样例输出 #1
.t.r
样例 #2
样例输入 #2
Codeforces
样例输出 #2
.c.d.f.r.c.s
样例 #3
样例输入 #3
aBAcAba
样例输出 #3
.b.c.b
代码
小白代码
// 118A String Task
/**
* CodeForces->力扣->洛谷->牛客->CodeForces
* 竞赛6P <训练>
* CodeForces+力扣+牛客+洛谷+ZZULIOJ+等等+CodeForces <比赛>
*
* 专注*行动*坚持*争分夺秒 <=> 算法竞赛金牌!!!
*
* 一心一意,10000小时,每天10小时+,两年九个月
*/
// 算法竞赛入门经典系列源码解析
// 算法竞赛入门经典第2版 P
// 算法竞赛入门经典 习题与解答 P
// 算法竞赛入门经典 训练指南 P
// 算法竞赛入门经典 算法实现 P
// 程序设计竞赛训练营
// 基础与数学概念 P
// 算法与实践 P
// 牛客练习
// 洛谷练习
// 力扣练习
// CodeForces 118A String Task
/*
Dreams never shine!
It's you that shine while chasing your dreams :)
JAYO!!
*/
/*
Vowels are letters "A", "O", "Y", "E", "U", "I",
*/
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cctype>
using namespace std;
int main() {
string line;
string ans = "";
int arr[128]{0};
cin >> line;
arr['A'] = arr['O'] = arr['Y'] = arr['E'] = arr['U'] = arr['I'] = 1;
arr['a'] = arr['o'] = arr['y'] = arr['e'] = arr['u'] = arr['i'] = 1;
for (auto m : line) {
if (!arr[m]) ans += ".", ans += tolower(m);
}
cout << ans << endl;
return 0;
}
大神代码
分析
主思路:先将大写字母转换为小写字母,再进行主判断(是否为辅音),元音略过
#include <bits/stdc++.h> //万能头文件
using namespace std;
string a; //定义一个字符串
int main()
{
cin >> a;
//输入,不用说了吧
int la = a.length(); //为了方便
for (int i = 0; i < la; i++)
{ //字符一律从0开始
if (a[i] >= 'A' && a[i] <= 'Z')
a[i] += 32;
//大写字母转小写字母
if (a[i] != 'a'
&& a[i] != 'o'
&& a[i] != 'y'
&& a[i] != 'e'
&& a[i] != 'u'
&& a[i] != 'i') //暴力判断
cout << "." << a[i];
//是辅音前面就输出“.”,
//然后是字符a[i]
}
return 0; //好习惯
}
总结
基础不牢,地动山摇
最后
以上就是含蓄可乐为你收集整理的18-CodeForces-118A-String TaskString Task代码总结的全部内容,希望文章能够帮你解决18-CodeForces-118A-String TaskString Task代码总结所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复