概述
Think:
1大数取模
2相似题目——可考虑快速幂优化
SDUT题目链接
sum of power
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
Calculate mod (1000000000+7) for given n,m.
Input
Input contains two integers n,m(1≤n≤1000,0≤m≤10).
Output
Output the answer in a single line.
Example Input
10 0
Example Output
10
Hint
Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)
以下为Accepted代码
#include <bits/stdc++.h>
using namespace std;
#define mod 1000000007///预定义
int main()
{
long long sum, sun;
int n, m, i, j;
while(scanf("%d %d", &n, &m) != EOF)
{
sum = 0;
for(i = 1; i <= n; i++){
sun = 1;
for(j = 0; j < m; j++){
sun = (sun * i) % mod;///及时取模,避免超出存储范围
}
sum = (sum + sun) % mod;///及时取模,避免超出数据范围
}
printf("%lldn", sum);
}
return 0;
}
/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 192KB
Submit time: 2017-05-11 21:19:26
****************************************************/
最后
以上就是鳗鱼高跟鞋为你收集整理的sum of power——大数取模的全部内容,希望文章能够帮你解决sum of power——大数取模所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复