我是靠谱客的博主 甜蜜大侠,最近开发中收集的这篇文章主要介绍[Loops]D. Liang 4.8 Finding the highest score.c,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description
Write a program that reads the number of students, each student’s score, and displays the highest score.
Input
The first line contains a positive integer n (n > 0), n is the number of students. The second line contains n positive integers seperated by one blank which are the students’ scores.
Output
The higithest score in one line. There is a newline at the end.
Sample Input
3
90 80 95
Sample Output
95

//  Date:2020/3/13
//  Author:xiezhg5 
#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n,a,max,i;
    scanf("%d",&n);
    scanf("%d",&max);     //max肯定在输入的数中 
    for(i=1;i<n;i++)     //n是输入整数的个数这里是循环次数 
    {
        scanf("%d",&a);    //读入所输入的整数 
        //用循环依次比较输入的数的大小
		//并将较大的数存放在max中 
        if(a>max)max=a;   
    }
    printf("%d",max);
    return 0;
}

最后

以上就是甜蜜大侠为你收集整理的[Loops]D. Liang 4.8 Finding the highest score.c的全部内容,希望文章能够帮你解决[Loops]D. Liang 4.8 Finding the highest score.c所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(63)

评论列表共有 0 条评论

立即
投稿
返回
顶部