我是靠谱客的博主 外向灯泡,最近开发中收集的这篇文章主要介绍VmatrixOJ--[Conditions]DescriptionInputOutputSample InputSample OutputCode: ,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Description
Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).
Input
The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.
Output
For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.
Sample Input
2
3
1 2 1
4
2 1 2 1
Sample Output
1 2
2 1
Code:
#include<stdio.h>
int main()
{
int CaseNum;
scanf("%d", &CaseNum);
int a[20][100];
int i, j, num[100];
for(i=0; i<CaseNum; i++){
scanf("%d", &num[i]);
for(j=0; j<num[i]; j++)
scanf("%d", &a[i][j]);
}
int k;
for(i=0; i<CaseNum; i++){
printf("%d", a[i][0]);
for(j=1; j<num[i]; j++){
for(k=0; k<j; k++){
if(a[i][k]==a[i][j])
break;
}
if(k==j)
printf(" %d", a[i][j]);
}
printf("n");
}
return 0;
}
最后
以上就是外向灯泡为你收集整理的VmatrixOJ--[Conditions]DescriptionInputOutputSample InputSample OutputCode: 的全部内容,希望文章能够帮你解决VmatrixOJ--[Conditions]DescriptionInputOutputSample InputSample OutputCode: 所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复