我是靠谱客的博主 懵懂月饼,最近开发中收集的这篇文章主要介绍1242Rescue (优先队列BFS),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

Sample Output
13
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
typedef struct nn
{
int x,y;
int time;
friend bool operator<(nn n1,nn n2)
{
return n2.time<n1.time;
}
}node;
int h,w,si,sj,di,dj,minT,flog;
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
char map[205][205];
void BFS(void)
{
int tx,ty,e,k,i;
priority_queue<node> Q;
node q,p;
q.time=0;q.x=sj;q.y=si;
Q.push(q);
while(!Q.empty())
{
q=Q.top();
Q.pop();
for(e=0;e<4;e++)
{
tx=q.x+dir[e][1];
ty=q.y+dir[e][0];
if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!='#')
{
p.time=q.time+1; p.x=tx; p.y=ty;
if(p.y==di&&p.x==dj)
{
minT=p.time;
flog=1;
return ;
}
if(map[ty][tx]=='x')
{
p.time+=1;//printf("#");
}
map[ty][tx]='#';
Q.push(p);
}
}
}
}
int main()
{
int i,j;
while(scanf("%d%d",&h,&w)>0)
{
for(i=0;i<h;i++)
{
getchar();
for(j=0;j<w;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='r')
{
si=i;sj=j;
}
if(map[i][j]=='a')
{
di=i;dj=j;
}
}
}
flog=0;
BFS();
if(flog==0)
printf("Poor ANGEL has to stay in the prison all his life.n");
else
printf("%dn",minT);
}
}


最后

以上就是懵懂月饼为你收集整理的1242Rescue (优先队列BFS)的全部内容,希望文章能够帮你解决1242Rescue (优先队列BFS)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(58)

评论列表共有 0 条评论

立即
投稿
返回
顶部