概述
题目链接:
http://poj.org/problem?id=3278
Catch That Cow
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 108478 | Accepted: 33877 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers:
N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
思路:一道基础的bfs水题,就是将一个数的周围三个点(x+1,x-1,2x)加入队列,要注意加入时需判断下表是否越界。为此RE四次。。。
上代码:
#include<cstdio>
#include<queue>
using namespace std;
int n,k;
typedef struct
{
int num;
int s;
}
Q;
int flag[200050];
int f=0;
int ans=-1;
void bfs(int x)
{
queue<Q> q;
int dx[3];
Q q1;
q1.num=x;
q1.s=0;
flag[x]=1;
q.push(q1);
while(!q.empty())
{
Q t=q.front();
q.pop();
if(t.num==k)
{
f=1;
ans=t.s;
break;
}
dx[0]=t.num-1;
dx[1]=t.num+1;
dx[2]=2*t.num;
for(int i=0;i<3;i++)
{
if(dx[i]>=0&&dx[i]<=100000&&flag[dx[i]]==0)
{
Q tq;
tq.num=dx[i];
tq.s=t.s+1;
flag[dx[i]]=1;
q.push(tq);
}
}
}
}
int main()
{
scanf("%d%d",&n,&k);
bfs(n);
if(f==1)
printf("%d",ans);
return 0;
}
最后
以上就是鳗鱼小甜瓜为你收集整理的POJ3278的全部内容,希望文章能够帮你解决POJ3278所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复