概述
Bus System
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6311 Accepted Submission(s): 1624
Total Submission(s): 6311 Accepted Submission(s): 1624
Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.
Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.
Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
Source
2008 “Sunline Cup” National Invitational Contest
这个题目一看本来不想用floyd的,但是后来看别人说数据水直接floyd就ok了,所以我也就偷偷懒啦,不过这个题最关键的是在转换成最短路径问题去,所以题目的看点不是求最短路径的算法,而是如何巧妙地转换成求最短路径。
代码如下:
这个题目一看本来不想用floyd的,但是后来看别人说数据水直接floyd就ok了,所以我也就偷偷懒啦,不过这个题最关键的是在转换成最短路径问题去,所以题目的看点不是求最短路径的算法,而是如何巧妙地转换成求最短路径。
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const long long max_dis=1e18;
//10的18次方
long long l1,l2,l3,l4;
long long c1,c2,c3,c4;
long long s[105];
long long dp[105][105];
int cost=0;
int n,m,t;
struct P{
int x,y;
}an[505];
void floyd()
{
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(dp[i][j]>dp[i][k]+dp[k][j])
dp[i][j]=dp[i][k]+dp[k][j];
}
int main()
{
scanf("%d",&t);
while(t--){
scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%I64d",&s[i]);
for(int i=1;i<=n;i++){
for(int j=i;j<=n;j++){
long long kk=abs(s[i]-s[j]);
if(kk==0)
dp[i][j]=dp[j][i]=0;
else if(kk>0&&kk<=l1)
dp[i][j]=dp[j][i]=c1;
else if(kk>l1&&kk<=l2) dp[i][j]=dp[j][i]=c2;
else if(kk>l2&&kk<=l3) dp[i][j]=dp[j][i]=c3;
else if(kk>l3&&kk<=l4) dp[i][j]=dp[j][i]=c4;
else
dp[i][j]=dp[j][i]=max_dis;
}
}
floyd();
cost++;
printf("Case %d:n",cost);
for(int i=0;i<m;i++)
scanf("%d%d",&an[i].x,&an[i].y);
for(int i=0;i<m;i++){
if(dp[an[i].x][an[i].y]==max_dis)
printf("Station %d and station %d are not attainable.n",an[i].x,an[i].y);
else
printf("The minimum cost between station %d and station %d is %I64d.n",
an[i].x,an[i].y,dp[an[i].x][an[i].y]);
}
}return 0;
}
最后
以上就是勤劳苗条为你收集整理的HDU-1690-还是最短路径(floyd)Bus System的全部内容,希望文章能够帮你解决HDU-1690-还是最短路径(floyd)Bus System所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复