概述
例6005 游船出租
Time Limit: 1000/1000MS (C++/Others) Memory Limit: 65536/65536KB (C++/Others)
Total Submissions: 143 Accepted Submissions: 63
Problem Description
现有公园游船租赁处请你编写一个租船管理系统。当游客租船时,管理员输入船号并按下S键,系统开始计时;当游客还船时,管理员输入船号并按下E键,系统结束计时。船号为不超过100的正整数。当管理员将0作为船号输入时,表示一天租船工作结束,系统应输出当天的游客租船次数和平均租船时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有租船没有还船,或者只有还船没有租船的纪录,系统应能自动忽略这种无效纪录。
Input
测试输入包含若干测试数据,每个测试数据为一整天的租船纪录,格式为:
船号(1~100) 键值(S或E) 发生时间(小时:分钟)
每一天的纪录保证按时间递增的顺序给出。当读到船号为-1时,全部输入结束,相应的结果不要输出。
Output
对每个测试数据输出1行,即当天的游客租船次数和平均租船时间(以分钟为单位的精确到个位的整数时间)。
Sample Input
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
-1
Sample Output
2 196
0 0
1 60
#include <stdio.h>
#include <string.h>
int count = 0;
int sumTime = 0;
struct Boat
{
char sw[4];
int time;
};
int main()
{
int h,m;
int num;
struct Boat b[110];
char temp[4];
while(1)
{
scanf("%d",&num);
if(num==-1) break;
scanf("%s %d:%d",&temp,&h,&m);
if(num==0)
{
if(count==0)
{
printf("0 0n");
continue;
}
else
{
printf("%d %.0fn",count,sumTime*1.0/count);
count = 0;
sumTime = 0;
}
for(int i = 0;i <110;i++)
{
b[i].sw[0] = '