概述
端口镜像:通过交换机的第2号口监控第1号口的流量
Switch(config)# monitor session 1 source interface gigabitethernet0/1
Switch(config)# monitor session 1 destination interface gigabitethernet0/2
Switch(config)# end
删除一个端口镜像会话:
Switch(config)# no monitor session 1 source interface gigabitethernet0/1
Switch(config)# end
以太通道端口组(Ethernet Port Groups)
以太通道端口组提供把多个交换机端口像一个交换端口对待。这些端口组为交换机之间或交换机和服务器之间提供一条单独的高带宽连接的逻辑端口。以太通道在一个通道中提供穿越链路的负载平衡。如果以太通道中的一个链路失效,流量会自动从失效链路转移到被用链路。你可以把多干道端口加到一个逻辑的干道端口;把多访问端口加到一个逻辑访问端口;或者多隧道端口加到一个逻辑的隧道接口。绝大多数的协议能够在单独或是集合的接口上运行,并且不会意识到在端口组中的物理端口。除了DTP、CDP和PAgP,这些协议只能在物理接口上运行。
当你配置一个以太通道,你创建一个端口通道逻辑接口,并且指派一个接口给以太通道。对于三层接口,你人工创建该逻辑接口:
Figure 33-1 Typical EtherChannel Configuration
举例:把交换机A,B的1,2号口添加到同一个组5里面
SwitchA# configure terminal
SwitchA (config)# interface range gigabitethernet0/1 -2
SwitchA (config-if-range)# switchport mode access
SwitchA (config-if-range)# switchport access vlan 10
SwitchA (config-if-range)# channel-group 5 mode ON
Switch(config-if-range)# end
可支持的VLAN
Catalyst 3560交换机支持1005个 VLAN,可以分别是VTP client, server, 及 transparent modes. VLAN号可以从1到4094. VLAN号1002到1005保留给令牌环及FDDI VLAN. VTP只能学习到普通范围的VLAN, 即从VLAN到1到1005; VLAN号大于1005属于扩展VLAN,不存在VLAN数据庫中。 交换机必须配置成VTP透明模式当需要生成VLAN 号从1006到4094.
本交换机支持基于每一VLAN的生成树(PVST),最多支持128个生成树。本交换机支持ISL及IEEE 802.1Q trunk二种封装。
配置VLAN Trunks
以太网端口有二种链路类型:Access和Trunk。Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;Trunk类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;这里的trunk并不是端口干路的概念,即端口汇聚或者链路聚合,而是允许vlan透传的一个概念。
命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface interface-id 进入端口配置状态
Step 3 switchport trunk encapsulation {isl | dot1q | negotiate} 配置trunk封装ISL 或 802.1Q 或自动协商
Step 4 switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。· dynamic auto—自动协商是否成为trunk· dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 或自动模式· trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk
Step 5 switchport access vlan vlan-id (可选) 指定一个缺省VLAN, 如果此端口不再是trunk
Step 6 switchport trunk native vlan vlan-id 指定802.1Q native VLAN号
Step 7 end 退出
Step 8 show interfaces interface-id switchport 显示有关switchport 的配置
Step 9 show interfaces interface-id trunk 显示有关trunk的配置
Step 10 copy running-config startup-config 保存配置
举例:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
缺省情况下trunk允许所有的VLAN通过。可以使用 switchport trunk allowed vlan remove vlan-list 来去掉某一VLAN
Command Purpose
Step 1 configure terminal 进入配置状态
Step 2 interface interface-id 进入端口配置
Step 3 switchport mode trunk 配置二层口为trunk
Step 4 switchport trunk allowed vlan {add | all | except | remove} vlan-list (可选) 配置trunk允许的VLAN. 使用add, all, except, remove关健字
Step 5 end 退出
Step 6 show interfaces interface-id switchport 验证VLAN配置情况.
Step 7 copy running-config startup-config 保存配置
回到允许所有VLAN通过时, 可用no switchport trunk allowed vlan 端口配置命令.
举例如下:
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
channel Group
交换机与交换的端口绑定可以用各种模式(on/active/active/auto/desirable/passive),接口类型也可以是多种(access/trunk..)但是,交换机与服务器的绑定模式和接口类型必须是(active/trunk)
<EtherChannel>
·通过这个技术能够将多个物理端口绑定为一个逻辑端口
通过多个端口绑定,能充分利用现有端口来增加带宽。
·Cisco交换机最多允许绑定8个端口。
如果是快速以太网,总带宽可达1600Mbit/s
如果是Gbit以太网,总带宽可达16Gbit/s
·绑定后的端口默认继承原来物理接口的配置模式。
·etherchannel不支持10M端口的绑定
·cisco的交换机不仅可以支持第二层etherchannel,还可以支持第三层etherchannel。
·一个etherchannel内所有的端口都必须具有相同的速率和双工模式。LACP只能是全双工。
二层接口和三层接口的区别:
二层接口不能配置IP地址,不能宣告进路由协议,只能对二层以太网帧进行转发。
三层接口可以配置IP地址,可运行路由协议,能接收IP包并且转发。
EtherChannel的模式:
可以直接将物理端口绑定,也可以让两台交换机之间通过协议进行协商,来形成channel通道。
On:强行起etherchannel
Sw1(config)#int range f0/8 ,f0/9 同时进入这2个接口的配置模式
Sw1(config-if-range)#channel-group 1 mode on 将这两个接口绑定为一组并指定on模式
组号只有本地意义 2端可以不一样
Sw1(config)#interface port-channel 1
Sw1(config-if)#switchport mode trunk 指定接口模式为trunk,如不指定,会自动继承物理接口的模式
Sw1#show etherchannel summary 可以看到绑定了多少接口
Show interface etherchannel
Port Aggregation Protocol (PAgP)端口汇聚协议
Cisco私有技术,这个协议又有两种模式:
auto:被动 只收不发
Desirable:主动 会发也会收协商消息
Sw1(config)#int range f0/8 ,f0/9
Sw1(config-if-range)#channel-group 1 mode desible
Sw1(config)#int range f0/8 ,f0/9
Sw1(config-if-range)#channel-group 1 mode auto
Sw1(config)#interface port-channel 1
Sw1(config-if)#switchport mode trunk
Link Aggregation Control Protocol (LACP) 链路聚合控制协议
802.3ad,业界标准
Passvie相当于PAgP的auto
Active相当于PAgP的desirable 又发又收协商消息
Sw1(config)#int range f0/8 ,f0/9
Sw1(config-if-range)#channel-group 1 mode passive
Sw1(config)#int range f0/8 ,f0/9
Sw1(config-if-range)#channel-group 1 mode active
Sw1(config)#interface port-channel 1
Sw1(config-if)#switchport mode trunk
show etherchannel 1 summary
show etherchannel summary 查看所有的group
还有一种好的办法是先对每个接口封装trunk,再划入channel-group中,channel-group接口会自动继承trunk
注:channel-group接口会自动继承第一个物理接口的接口配置模式,或最先配置的接口模式。
配置三层channel
所谓三层的channel其实就是将多个三层接口绑定。只能在三层交换机上配置。
在3550这样的交换机上,所有接口默认都是二层接口。首先需要将交换机的的二层接口改为三层接口。可用以下命令实现:
3550(config)#interface gigabitethernet 0/1
3550(config-if)#no switchport
然后再绑定:
3550(config-if)#channel-group 1 mode desirable
3550(config-if)#exit
将另一个端口也绑进来
3550(config)#interface gigabitethernet 0/2
3550(config-if)#no switchport
3550(config-if)#channel-group 1 mode desirable
3550(config-if)#exit
给channel通道配上IP地址:
3550(config)#interface port-channel 1
3550(config-if)#ip address 100.1.1.1 255.255.255.0
配置etherchannel负载均衡
默认情况下是基于源MAC地址的负载均衡
port-channel load-balance [dst-mac|src-mac] 改基于什么做负载均衡
show etherchannel load-balance 查看交换机什么做负载均衡
Err-disable特性:
接口如果进入err-disable状态:有两种方法恢复
1、手动恢复
先shutdown、再no shutdown
2、自动恢复
errdisable recovery cause {all|arp-inspection|bpduguard|link-flap} 指定原因
errdisable recovery interval 30 指定自动恢复时间间隔
转载于:https://blog.51cto.com/landl/609149
最后
以上就是知性咖啡豆为你收集整理的交换机命令的全部内容,希望文章能够帮你解决交换机命令所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复