概述
题目:http://poj.org/problem?id=1700
Crossing River
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 12177 | Accepted: 4613 |
Description
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1 4 1 2 5 10
Sample Output
17分析:大意是,一艘船一次最多能载两个人,过河的速度由最慢的那个人决定,现在有N个人需要过河,船划过上岸后如果还有没过河的人就需要再把船划回去。
题目的例子我就看了半天,如果能把例子看懂,这题也基本会做大半了。
过河的两种方式:
刚开始我只想到(2)||-_- 不是所有的情况下都是第一种情况占优,当遇到只有3个人时肯定是第一种以最少耗时的人送人划回船的方案合适。于是贪心和动态规划的思路就形成了。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int p[1005],dp[1005];
int main()
{
//freopen("cin.txt","r",stdin);
int t,n;
cin>>t;
while(t--){
scanf("%d",&n);
for(int i=0;i<n;i++) scanf("%d",&p[i]);
sort(p,p+n);
dp[0]=p[0];
dp[1]=p[1];
for(int i=2;i<n;i++){
int t1=dp[i-1]+p[i]+p[0],t2=dp[i-2]+2*p[1]+p[0]+p[i];
dp[i]=min(t1,t2);
}
printf("%dn",dp[n-1]);
}
return 0;
}
最后
以上就是无心奇迹为你收集整理的poj 1700 Crossing River(贪心·dp)的全部内容,希望文章能够帮你解决poj 1700 Crossing River(贪心·dp)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复